Project

General

Profile

Feature #23928

Add ability to send test alert to Alert Services

Added by Chris Heerschap over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Testing the Alert Services in 11RC1 I don't see a way to send a test alert, such as exists when setting up email alerts. This would be a very valuable addition to the Alert Services tab.


Related issues

Is duplicate of FreeNAS - Feature #24577: There are no ways to test alert services configurationClosed: Duplicate2017-06-16

Associated revisions

Revision 7f37770c (diff)
Added by Marcelo Araujo over 1 year ago

feat(consul): Add the capability to reload consul agent via websocket. It will be used later on to send test alerts.

Ticket: #23928

Revision 1ca353fe (diff)
Added by Marcelo Araujo over 1 year ago

feat(consul): Add auxiliary methods to create and destroy fake alert.

Ticket: #23928

Revision af4e3d95 (diff)
Added by Marcelo Araujo over 1 year ago

feat(gui/consul): Allow users to send fake alert in 'Alert Services'.

Ticket: #23928

Revision f523a905 (diff)
Added by Dru Lavigne about 1 year ago

Add Send Test Alert button.
Ticket: #23928

History

#1 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Marcelo Araujo

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Priority changed from Important to Nice to have
  • Target version set to 11.1

#3 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened

#4 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Screened to Resolved

#5 Updated by Marcelo Araujo over 1 year ago

After you setup the Service and save it, if you edit it again a new button called 'Send fake alert' will appear, as soon as you click on it, it will create a fake alert and services like Pagerduty will trigger it, however it is not in real time.

Thanks for the suggestion, very useful.

#6 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Feature #24577: There are no ways to test alert services configuration added

#8 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#9 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Test passed in FreeNAS-11-MASTER-201710180506

Also available in: Atom PDF