Project

General

Profile

Bug #23942

Active Directory Provisioning succeeds but throws timeout traceback

Added by Michael Dexter over 3 years ago. Updated over 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Exact version: FreeNAS-11-MASTER-201705120409 (985e5c7)

Services: Domain Controller will provision an AD DC but the process exceeds the GUI timeout, resulting in a traceback.

Discussed with: John Hixson

History

#1 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.0

#2 Updated by John Hixson over 3 years ago

  • Status changed from Screened to 15

Can you post the stack trace you get? Please attach a debug as well.

#3 Updated by Michael Dexter over 3 years ago

  • File debug-freenas-20170512165331.tgz added

Request Method: POST
Request URL: http://10.0.0.150/admin/services/domaincontroller/edit/1/
Software Version: FreeNAS-11.0-RC (ad90a865b)
Exception Type: CallTimeout
Exception Value:
Call timeout
Exception Location: /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 204
Server time: Fri, 12 May 2017 16:50:27 -0700
Traceback

Request information

GET

No GET data
POST

Variable Value
all ''
dc_realm 'EXAMPLE.LAN'
dc_domain 'EXAMPLE'
dc_role 'dc'
dc_dns_forwarder '127.0.0.1'
dc_forest_level '2003'
dc_passwd 'passw0rd!'
dc_passwd2 'passw0rd!'
dc_kerberos_realm ''
__form_id 'dialogForm_domaincontroller'
FILES

No FILES data
COOKIES

Variable Value
csrftoken '0cfZr8vmpDJZzHuYEuF2Cq7n1rHoYyzhD5Cisf9RqCEH9vagfl872AD12VJN9QNj'
fntreeSaveStateCookie 'root'
sessionid 'nk9fbmw49l8c922noj9dsod0pxpz0rby'
META

Variable Value

#4 Updated by Dru Lavigne over 3 years ago

Will a fix for this make it into 11?

#5 Updated by John Hixson over 3 years ago

I'm working very hard to fix the various DC issues to get this in the release.

#6 Updated by John Hixson over 3 years ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from John Hixson to Vaibhav Chauhan
  • Target version changed from 11.0 to 11.0-RC3

#7 Updated by Vaibhav Chauhan over 3 years ago

which project does this FIX branches belong to?

#8 Updated by Vaibhav Chauhan over 3 years ago

  • Assignee changed from Vaibhav Chauhan to John Hixson

#9 Updated by John Hixson over 3 years ago

  • Status changed from Needs Developer Review to Closed: Duplicate

This ticket is a duplicate of #23566. All work done for this ticket was posted to that ticket. Closing out since that ticket is the key master. No course of action needs to be done here ;-)

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Target version changed from 11.0-RC3 to N/A

#11 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20170512165331.tgz)

Also available in: Atom PDF