Project

General

Profile

Bug #23950

Unlock encrypted pool time out

Added by charles selfridge over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Blocks Until Resolved
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When unlocking my encrypted pool / restarting services at boot I received the fallowing. It did at some point come back with an unlocked pool.


Related issues

Is duplicate of FreeNAS - Bug #24047: Unable to create encrypted volume with expansion storageClosed: Duplicate2017-05-18

Associated revisions

Revision fdc22715 (diff)
Added by William Grzybowski over 3 years ago

devel/py-gevent: make sure to use /dev/fd to close fds Ticket: #23950

Revision 3053b383 (diff)
Added by William Grzybowski over 3 years ago

devel/py-gevent: make sure to use /dev/fd to close fds Ticket: #23950 (cherry picked from commit fdc227158a13c676eceb5fa1bb0ef8e5c17ad596)

Revision 90b593bf (diff)
Added by William Grzybowski over 3 years ago

devel/py-gevent: bump portrevision Ticket: #23950

Revision 3d9c8fe3 (diff)
Added by William Grzybowski over 3 years ago

devel/py-gevent: bump portrevision Ticket: #23950

History

#1 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to 15

Please attach, Save Debug (System - Advanced)

#2 Updated by charles selfridge over 3 years ago

  • File debug-The-Archive-20170513024557.tgz added

#4 Updated by charles selfridge over 3 years ago

  • Target version set to 11.0

#5 Updated by William Grzybowski over 3 years ago

  • Priority changed from No priority to Nice to have

Your debug does not have any useful information, unfortunately.

Does those errors you took screenshot happen on every boot?

#6 Updated by charles selfridge over 3 years ago

It does, check the second debug I uploaded debug-The-Archive-20170513033556.tgz, that one probably has what you are looking for. I took the first one from 9.10 thinking that the log@ redirected logs across boot environments, but I think I assumed wrong.

#7 Updated by William Grzybowski over 3 years ago

charles selfridge wrote:

It does, check the second debug I uploaded debug-The-Archive-20170513033556.tgz, that one probably has what you are looking for. I took the first one from 9.10 thinking that the log@ redirected logs across boot environments, but I think I assumed wrong.

I could not find anything in either.
On boot middlewared is not starting or taking too long to.

Did you try to verify the installation in System -> Update -> Verify Install.

Also, any chance I can get SSH or TeamViewer access to debug?

#8 Updated by charles selfridge over 3 years ago

Sure, what time slots do you have open, I am AFK from ~10am - 7pm EST M-F.

#9 Updated by William Grzybowski over 3 years ago

charles selfridge wrote:

Sure, what time slots do you have open, I am AFK from ~10am - 7pm EST M-F.

I am available from 8am - 5pm EDT.

william at ixsystems com

#10 Updated by William Grzybowski over 3 years ago

  • Status changed from 15 to Screened
  • Priority changed from Nice to have to Blocks Until Resolved

After the session I did pinpoint the issue as a problem with python and huge memory systems (number of open files).

Will be investigating on how to better solve that.

#11 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to Needs Developer Review
  • Seen in changed from 11.0-RC to 11.0-RC2

Kris, please review.

Fix branch is in ports repo. This is a patch to gevent to close fds using /dev/fd instead of looping through all (MAXFD).

#12 Updated by William Grzybowski over 3 years ago

  • Assignee changed from William Grzybowski to Kris Moore

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Assignee changed from Kris Moore to Brandon Schneider

Let me pass this over to Brandon. There's enough python here that I'm not 100% I can review it properly ;)

#14 Updated by William Grzybowski over 3 years ago

  • Is duplicate of Bug #24047: Unable to create encrypted volume with expansion storage added

#15 Updated by Brandon Schneider over 3 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from Brandon Schneider to William Grzybowski

LGTM

#16 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed to Merged
  • Target version changed from 11.0 to 11.0-RC3

#17 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Merged to Resolved

#18 Updated by charles selfridge over 3 years ago

Thanks guys.

#19 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-The-Archive-20170513024557.tgz)

#20 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-The-Archive-20170513033556.tgz)

Also available in: Atom PDF