Project

General

Profile

Bug #23956

SMB failed

Added by Julien Bénic over 3 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Timur Bakeyev
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

hi,
just sumib 2 bug
SMB,
If you change or just wait because this service have an error, all share are missing.
I have test smb4 and just see general category!
Where are all share?

For correcting this bug, just apply this command:
python /usr/local/libexec/nas/generate_smb4_conf.py

and test param for smb4 and all are good.

FTP,
Also there are an problem with FTP service, impossible to connect.
Just migrating freenas 9.10.2-U3 to freenas 11 RC stable.


Related issues

Related to FreeNAS - Bug #24973: Keep LC_ALL and LANG variables when starting a serviceResolved2017-07-03

History

#1 Updated by John Hixson over 3 years ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

Please attach a debug: system->advanced->save debug

#2 Updated by Julien Bénic over 3 years ago

  • File debug-MotorHome-20170515223334.tgz added

[SMB]
I found a problem for SMB failed.

In FreeNAS-9.10.2-U3 version, there is not a problem but in FreeNAS-11-RC = I don't see any share directory.
Why?
Because the name of the share have accent or/and have special character in hostallow or hostdeny.

Good working => Name: Ma Bibliotheque Comment : Bibliotheque
Bad working => Name: Ma Bibliothèque Comment : Bibliothèque

[FTP]
FTP doesn't work in this version , couldn't connect then working in Freenas 9.10.2-U3
Thanks for all

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Seen in changed from Unspecified to N/A

#4 Updated by John Hixson about 3 years ago

  • Status changed from 15 to Screened
  • Assignee changed from John Hixson to Timur Bakeyev

Timur, this is related to the fix William & you did, so passing along to you.

#5 Updated by Julien Bénic about 3 years ago

  • Target version changed from 11.1 to 11.2-BETA1
  • Seen in changed from N/A to 11.0-U2

Hi,

I have migrate to FreeNAS-11.0-U2 (e417d8aa5).
I confirme this bug are already present.
Just Name in share windows (CIFS) have a [é,è etc...] and samba doesn't works.

Julien

#6 Updated by Timur Bakeyev about 3 years ago

  • Status changed from Screened to 15

Hi!

The good news is that the problem with the shares with non-ascii names should be resolved by patch in the #24973. It is scheduled to the 11.0-U3, which should come in few weeks. In theory you can apply the patch manually, if you don't want to wait, but in general we don't encourage that.

As for the FTP problem - please, open a separate ticket, if it's still the case.

#7 Updated by Timur Bakeyev about 3 years ago

  • Related to Bug #24973: Keep LC_ALL and LANG variables when starting a service added

#8 Updated by Timur Bakeyev about 3 years ago

  • Target version changed from 11.2-BETA1 to 11.0-U3

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from 15 to Closed: Duplicate
  • Target version changed from 11.0-U3 to N/A

Closing as Duplicate of #24973

#10 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-MotorHome-20170515223334.tgz)

#11 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF