Project

General

Profile

Bug #23974

VM VNC Device is unreliable when VNC port is empty

Added by Stuart Espey over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

By default, the VM VNC device is configured for 0, which is auto. or perhaps its blank, but it works.

If you change the VNC setting, say by disabling Wait to boot, then the VNC device will no longer function.

By setting the VNC port to 0 instead of blank, then it will work correctly.

There was a similar issue in 9.10.something to do with iSCSI in the past.

I supect what's happening is the default value of "" is not working on update.

In FreeNAS 11-RC

Screen Shot 2017-05-16 at 2.19.28 PM.png (20.4 KB) Screen Shot 2017-05-16 at 2.19.28 PM.png assign it a cloned zvol of a working vm as disk, set virtio Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.19.02 PM.png (28.1 KB) Screen Shot 2017-05-16 at 2.19.02 PM.png create a new vm Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.20.41 PM.png (14 KB) Screen Shot 2017-05-16 at 2.20.41 PM.png start the vm. it starts. can connect via vnc Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.19.41 PM.png (16.9 KB) Screen Shot 2017-05-16 at 2.19.41 PM.png set nic to virtio Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.20.47 PM.png (10.4 KB) Screen Shot 2017-05-16 at 2.20.47 PM.png stop the vm Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.12 PM.png (10.4 KB) Screen Shot 2017-05-16 at 2.21.12 PM.png the devices Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.05 PM.png (12.6 KB) Screen Shot 2017-05-16 at 2.21.05 PM.png it stops Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.19 PM.png (18.1 KB) Screen Shot 2017-05-16 at 2.21.19 PM.png modify nic, disable wait to boot, not port is blank by default Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.38 PM.png (12.4 KB) Screen Shot 2017-05-16 at 2.21.38 PM.png can not start vm Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.29 PM.png (14 KB) Screen Shot 2017-05-16 at 2.21.29 PM.png note vnc port now disappears Stuart Espey, 05/15/2017 09:25 PM
Screen Shot 2017-05-16 at 2.21.52 PM.png (18 KB) Screen Shot 2017-05-16 at 2.21.52 PM.png open vnc device, not blank port Stuart Espey, 05/15/2017 09:32 PM
Screen Shot 2017-05-16 at 2.22.08 PM.png (14.3 KB) Screen Shot 2017-05-16 at 2.22.08 PM.png vm list, port is not auto value Stuart Espey, 05/15/2017 09:32 PM
Screen Shot 2017-05-16 at 2.21.58 PM.png (18.3 KB) Screen Shot 2017-05-16 at 2.21.58 PM.png set port to 0 Stuart Espey, 05/15/2017 09:32 PM
Screen Shot 2017-05-16 at 2.22.19 PM.png (9.47 KB) Screen Shot 2017-05-16 at 2.22.19 PM.png start vm Stuart Espey, 05/15/2017 09:32 PM
Screen Shot 2017-05-16 at 2.22.23 PM.png (11.6 KB) Screen Shot 2017-05-16 at 2.22.23 PM.png vm starts Stuart Espey, 05/15/2017 09:32 PM
11127
11128
11129
11130
11131
11132
11133
11134
11135
11136
11137
11138
11139
11140
11141

Associated revisions

Revision 5b12bc94 (diff)
Added by Marcelo Araujo over 3 years ago

fix(gui/vm): When we create a new VM, by default the VNC_PORT is auto generated, however the form field doesn't know about this value and shows it empty. Ticket: #23974

Revision 1fb4b3b3 (diff)
Added by Marcelo Araujo over 3 years ago

fix(gui/vm): When we create a new VM, by default the VNC_PORT is auto generated, however the form field doesn't know about this value and shows it empty. Partially cherry-picked from: 5b12bc94246fde3e1d8b132cccc9c987765c39d7 and cc09a65b1f3173c1147e3a6acbaee2d0e8a1ad6b Ticket: #23974

History

#1 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Target version set to 11.0

#2 Updated by Marcelo Araujo over 3 years ago

  • Status changed from Screened to 15

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

#3 Updated by Stuart Espey over 3 years ago

Marcelo Araujo wrote:

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

No. There's a bug.

If you create a new VM, and don't modify the VNC device, it works in auto/default mode. But if you then modify the VNC device, the port becomes blank, not zero, and then the VNC doesn't work. Setting it to 0 resolves the problem.

I've taken some screenshots of reproduction I just made. Will upload and post a detailed walk through

#4 Updated by Marcelo Araujo over 3 years ago

Stuart Espey wrote:

Marcelo Araujo wrote:

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

No. There's a bug.

If you create a new VM, and don't modify the VNC device, it works in auto/default mode. But if you then modify the VNC device, the port becomes blank, not zero, and then the VNC doesn't work. Setting it to 0 resolves the problem.

I've taken some screenshots of reproduction I just made. Will upload and post a detailed walk through

OK, Understood! I'm installing now RC version and will make tests. It works OK on Nightlies version, but I might forgot to merge something back to STABLE version.

Thank you again! BTW, thanks for test the VM feature, I like your reports ;)

Best,

#5 Updated by Stuart Espey over 3 years ago

11127
11128
11129
11130
11131
11132
11133
11134
11135
11136

Stuart Espey wrote:

Marcelo Araujo wrote:

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

No. There's a bug.

If you create a new VM, and don't modify the VNC device, it works in auto/default mode. But if you then modify the VNC device, the port becomes blank, not zero, and then the VNC doesn't work. Setting it to 0 resolves the problem.

I've taken some screenshots of reproduction I just made. Will upload and post a detailed walk through

Can't upload any more screenshots.

Anyway, process to test

1) create a new vm
2) assign it a cloned zvol of a working vm's disk, set to virtio
3) set nic to virtio
4) start the VM, it starts, can connect via VNC to the port in the vm list
5) stop the vm
6) modify the VNC device to disable "wait to boot", note that the port is now blank, rather than 0.
7) in the VM list the port is now blank, rather than auto-value
8) try to start the VM. it won't.
9) open the VNC device, set port to 0, save
10) now the port appears in the VM list, and the VM can be started.

#6 Updated by Stuart Espey over 3 years ago

11137
11138
11139
11140
11141

Stuart Espey wrote:

Stuart Espey wrote:

Marcelo Araujo wrote:

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

No. There's a bug.

If you create a new VM, and don't modify the VNC device, it works in auto/default mode. But if you then modify the VNC device, the port becomes blank, not zero, and then the VNC doesn't work. Setting it to 0 resolves the problem.

I've taken some screenshots of reproduction I just made. Will upload and post a detailed walk through

Can't upload any more screenshots.

Anyway, process to test

1) create a new vm
2) assign it a cloned zvol of a working vm's disk, set to virtio
3) set nic to virtio
4) start the VM, it starts, can connect via VNC to the port in the vm list
5) stop the vm
6) modify the VNC device to disable "wait to boot", note that the port is now blank, rather than 0.
7) in the VM list the port is now blank, rather than auto-value
8) try to start the VM. it won't.
9) open the VNC device, set port to 0, save
10) now the port appears in the VM list, and the VM can be started.

So, the issue is either the default should be "0", or blank should be interpreted as zero. because if a user or the ui puts a blank port in the VM mysteriously (and without error) stops working.

#7 Updated by Stuart Espey over 3 years ago

Marcelo Araujo wrote:

Stuart Espey wrote:

Marcelo Araujo wrote:

It looks like, it works as expected.

1) When you add a VNC device, by default the VNC Port is 0 that means it will be auto generated.
2) When you click in OK, it will replace the value 0 to the auto generated value.
3) If you change any option as example: "Wait to boot" it still works.

As I understood, you were expecting it will be always 0, isn't it?

Best,

No. There's a bug.

If you create a new VM, and don't modify the VNC device, it works in auto/default mode. But if you then modify the VNC device, the port becomes blank, not zero, and then the VNC doesn't work. Setting it to 0 resolves the problem.

I've taken some screenshots of reproduction I just made. Will upload and post a detailed walk through

OK, Understood! I'm installing now RC version and will make tests. It works OK on Nightlies version, but I might forgot to merge something back to STABLE version.

Thank you again! BTW, thanks for test the VM feature, I like your reports ;)

Best,

Sorry about spamming the pictures :)

Hopefully you still like my bug reports ;)

Looking forward to being able to use the VM stuff in production.

#8 Updated by Marcelo Araujo over 3 years ago

  • Target version changed from 11.0 to 11.0-RC2

#9 Updated by Vaibhav Chauhan over 3 years ago

  • Target version changed from 11.0-RC2 to 11.0

#10 Updated by Dru Lavigne over 3 years ago

Will this make it into 11?

#11 Updated by Marcelo Araujo over 3 years ago

Dru Lavigne wrote:

Will this make it into 11?

Yes it should!!! Thanks Dru.

#12 Updated by Marcelo Araujo over 3 years ago

  • Status changed from 15 to Needs Developer Review
  • Assignee changed from Marcelo Araujo to William Grzybowski

#13 Updated by William Grzybowski over 3 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from William Grzybowski to Marcelo Araujo

lgtm

#14 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed to Merged
  • Target version changed from 11.0 to 11.0-RC3

#15 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Merged to Resolved

Also available in: Atom PDF