Project

General

Profile

Bug #23985

ctld restarted, not reloaded when creating extent or associating extent to target

Added by Alexander Schmid over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

obviously service ctld restart is issued, what causes connection error.
as i read sending SIGHUP, what service ctld reload does, would be sufficient.

tested with latest 9.x and proxmox on an iscsi-target.
all vm's running on the target stop when manually adding an extent or associating an extent to the target in the gui,
can be reproduced quite reliable.

tested the same with
service ctld reload -> good
service ctld restart -> same behaviour, vm's stop, connection error

The same happens when creating extents / assigning to targets via REST API (where i initially noticed the vm's stopping)

History

#1 Updated by Alexander Motin over 3 years ago

  • Status changed from Unscreened to Screened

Originally there were some things that could not be changed with simple reload, requiring restart. It needs review of all cases where CTL configuration changes.

#2 Updated by Alexander Motin over 3 years ago

  • Priority changed from No priority to Nice to have
  • Target version set to 11.1

#3 Updated by Alexander Motin almost 3 years ago

  • Status changed from Screened to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

It seems this problem was already fixed at some point. I looked into the code and tested recent nightly build and as I see ctld is always reloaed, not restarted. May be it is not good either, since not all properties can be changed that way now, but that is what it is right now.

#4 Updated by Alexander Motin almost 3 years ago

  • Status changed from Closed: Cannot reproduce to Closed: Behaves correctly

Also available in: Atom PDF