Project

General

Profile

Bug #24049

Only snapshot imported volumes

Added by William Grzybowski over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related issues

Is duplicate of FreeNAS - Bug #20492: Snapshots do not check if drive has been unlockedClosed: Duplicate2017-01-23

Associated revisions

Revision 258c1159 (diff)
Added by William Grzybowski over 1 year ago

fix(snap): make sure volume is imported before snapshot

Ticket: #24049

Revision e8dcd58e (diff)
Added by William Grzybowski over 1 year ago

fix(snap): make sure volume is imported before snapshot

Ticket: #24049
(cherry picked from commit 258c11593da62555826ac6cf32b8f23b3e16533a)

Revision 44a797cb (diff)
Added by William Grzybowski over 1 year ago

fix(snap): actually skip task if pool is not imported

Ticket: #24049

Revision 7f207e51 (diff)
Added by William Grzybowski over 1 year ago

fix(snap): actually skip task if pool is not imported

Ticket: #24049

History

#1 Updated by William Grzybowski over 1 year ago

  • Status changed from Fix In Progress to Needs Developer Review
  • Assignee changed from William Grzybowski to Brandon Schneider

#2 Updated by Brandon Schneider over 1 year ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from Brandon Schneider to William Grzybowski

LGTM

#3 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Reviewed to Merged
  • Target version changed from 11.0 to 11.0-RC3

#4 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Merged to Resolved

#5 Updated by charles selfridge over 1 year ago

Thanks William, I had forgotten to ask you if you wanted me to put this in or not and then I forgot to ask. >_>

#6 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Bug #20492: Snapshots do not check if drive has been unlocked added

#7 Updated by William Grzybowski over 1 year ago

  • Target version changed from 11.0-RC3 to 11.1

#8 Updated by William Grzybowski over 1 year ago

  • Status changed from Resolved to Ready For Release

#9 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Snapshotter will try to snapshot not imported pool (e.g. locked) to Only snapshot imported volumes

#10 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#11 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#12 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Also available in: Atom PDF