Project

General

Profile

Bug #24050

Enabling dhcp wipes default route

Added by Joe Maloney over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Critical
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

To reproduce I added a static IP 192.168.60.2/24 on igb1, and added a default route 192.168.60.1 from netcli. I then then configured igb0 for dhcp and replaced the default route with 10.20.0.1 after subsequent reboots as well. Running netstat -r will show 10.20.0.1 as the default route, and 192.168.60.1 is nowhere to be found.

Associated revisions

Revision a6b43a4f (diff)
Added by William Grzybowski over 3 years ago

fix(middlewared): use correct keyword for routers option Ticket: #24050

Revision bfeb1d5f (diff)
Added by William Grzybowski over 3 years ago

fix(netcli): do not remove default route when setting interface to DHCP Ticket: #24050

Revision ccc5e80b (diff)
Added by William Grzybowski over 3 years ago

fix(middlewared): use correct keyword for routers option Ticket: #24050 (cherry picked from commit a6b43a4f27dd537cb09392a5fe09c44f430f28f2)

Revision 3b18de7e (diff)
Added by William Grzybowski over 3 years ago

fix(netcli): do not remove default route when setting interface to DHCP Ticket: #24050 (cherry picked from commit bfeb1d5f99ddedee4c2282cb1ae02e1b2243b9b6)

History

#2 Updated by Joe Maloney over 3 years ago

If I add a static route again after enabling DHCP the problem is resolved. So it seems that the problem is certainly triggered by enabling DHCP on an adapter using netcli.

#3 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Critical
  • Target version set to 11.0

#4 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to 19

I could not reproduce but found an issue in dhclient.conf.

Wait for Joe to test a new internal nightly.

#5 Updated by Vaibhav Chauhan over 3 years ago

  • Target version changed from 11.0 to 11.0-RC3

#6 Updated by William Grzybowski over 3 years ago

  • Status changed from 19 to Needs Developer Review
  • Assignee changed from William Grzybowski to John Hixson

#7 Updated by John Hixson over 3 years ago

  • Status changed from Needs Developer Review to Reviewed
  • Assignee changed from John Hixson to Vaibhav Chauhan

Tested and confirmed working.

#8 Updated by William Grzybowski over 3 years ago

  • Assignee changed from Vaibhav Chauhan to William Grzybowski

#9 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed to Merged

#10 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Merged to Resolved

Also available in: Atom PDF