Project

General

Profile

Bug #24075

eventlet causing middlewared to get stuck

Added by William Grzybowski over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Blocks Until Resolved
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

gevent and eventlet cannot coexist, this is likely because of the import of the GUI code.

Associated revisions

Revision 00f35933 (diff)
Added by William Grzybowski over 3 years ago

fix(gui): lets get rid of eventlet and use thread pool gevent and eventlet cannot coexist, lets get rid of eventlet in gui since middlewared imports gui code to hope it will fix the issue of it getting stuck. Ticket: #24075

Revision ec6efb88 (diff)
Added by William Grzybowski over 3 years ago

fix(gui): lets get rid of eventlet and use thread pool gevent and eventlet cannot coexist, lets get rid of eventlet in gui since middlewared imports gui code to hope it will fix the issue of it getting stuck. Ticket: #24075 (cherry picked from commit 00f359337e95c5b2cef5937f361b3c51d32db692)

History

#1 Updated by William Grzybowski over 3 years ago

  • Status changed from Fix In Progress to Needs Developer Review
  • Assignee changed from William Grzybowski to John Hixson

#2 Updated by John Hixson over 3 years ago

  • Status changed from Needs Developer Review to Reviewed

Confirmed this works with William yesterday. The only thing I would add is that needs to be done in fn9_head as well (removable of the port in the build anyway).

#3 Updated by John Hixson over 3 years ago

  • Assignee changed from John Hixson to Vaibhav Chauhan

#4 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed to Merged

#5 Updated by William Grzybowski over 3 years ago

  • Assignee changed from Vaibhav Chauhan to William Grzybowski

#6 Updated by Vaibhav Chauhan over 3 years ago

  • Target version changed from 11.0 to 11.0-RC3

#7 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Merged to Resolved

Also available in: Atom PDF