Project

General

Profile

Bug #24076

FreeNAS-11.0-RC (ad90a865b) Update to RC2

Added by Saeed Ibrahim over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I update to latest Stable train my FreeNAS is stuck in a reboot cycle it reaches the Freenas boot screen where it says GRUB and it reboots again.

I have reinstalled the freenas and updated to RC2 on a fresh install.Then i updated my config file (.db file) and it keeps going into a reboot cycle

http://update.ixsystems.com/FreeNAS/FreeNAS-11-STABLE/Notes/ChangeLog-RA2I6_.txt

History

#1 Updated by Saeed Ibrahim over 3 years ago

  • ChangeLog Entry updated (diff)

#2 Updated by Sean Fagan over 3 years ago

  • Status changed from Unscreened to Closed: Insufficient Info

The logs indicate the update completed successfully. The behaviour you describe seems to indicate that the upgrade failed, or didn't finish. Or a some sort of disk error.

Unfortunately I can't figure out what happened here. You did the right thing by re-installing -- although I think you probably could have done an install to a new BE, for future reference.

#3 Updated by Saeed Ibrahim over 3 years ago

  • File Freenas update Reboot cycle.avi added

I have tried to update again via the Update tab in GUI. The Update completed successfully with no issues but, it keeps having a reboot cycle.

I have attached a small video recording of what happens when the NAS reboots

#4 Updated by Sean Fagan over 3 years ago

  • Status changed from Closed: Insufficient Info to 15

I don't think I have any idea what's going on there, then.

The fact that it boots post-install but then not after an update is pretty inexplicable.

I think you're going to have to do an install again. This time, please attach /boot/grub/grub.cfg before doing an update -- and then from after, but before rebooting. (Do "freenas-update -v -B no update", then attach /boot/grub/grub.cfg after that.)

#5 Updated by Saeed Ibrahim over 3 years ago

I dunno how I fixed it. Instead of using the FreeNAS 11 RC iso i downloaded 9.10 iso and updated it to 11 RC 2

I uploaded my db file and it worked fine now

#6 Updated by Sean Fagan over 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce

#7 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20170520100052.tgz)

#8 Updated by Dru Lavigne almost 3 years ago

  • Target version set to N/A

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (Freenas update Reboot cycle.avi)

Also available in: Atom PDF