Project

General

Profile

Feature #24347

Add bridge support

Added by Nik Isele over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Low
Reason for Closing:
Not to be fixed
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

I need to be able to create a bridge in order to use my multiple 10Gb NICs as a "switch". Would be great to have this new feature or at least a workaround. This is the only feature that keeps me sticking to Corral at the moment.


Related issues

Has duplicate FreeNAS - Bug #33534: No Bridge Network in GUIClosed
Is duplicate of FreeNAS - Bug #27122: Add overhauled bridge support to APIDone

History

#1 Updated by William Grzybowski over 2 years ago

  • Status changed from Unscreened to Screened
  • Target version changed from 11.0-RC2 to 11.2-BETA1

#2 Updated by William Grzybowski almost 2 years ago

  • Target version changed from 11.2-BETA1 to 11.3

This is probably going to have to wait 11.3

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 2 years ago

  • Status changed from Screened to Not Started

#4 Avatar?id=13649&size=24x24 Updated by Ben Gadd over 1 year ago

  • Target version changed from 11.3 to Backlog

#5 Updated by William Grzybowski over 1 year ago

  • Severity set to Low

#6 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #33534: No Bridge Network in GUI added

#8 Updated by Stephen Griffiths over 1 year ago

Nik Isele wrote:

I need to be able to create a bridge in order to use my multiple 10Gb NICs as a "switch". Would be great to have this new feature or at least a workaround. This is the only feature that keeps me sticking to Corral at the moment.

I hope this is not put on Back Burner due to the Corral Question, as this is also a problem with current releases. I also have 10 GB links and have to create bridge with post init script, then list 0.0.0.0 to listen on. would be nice to have the Bridge Option.
Or at least some one to make ctl.conf persistent with reboots.

#9 Updated by Dru Lavigne about 1 year ago

  • Target version changed from Backlog to 11.3

#10 Updated by Dru Lavigne about 1 year ago

#11 Updated by Dru Lavigne about 1 year ago

  • Related to deleted (Umbrella #50841: Network Interfaces Management Rewrite)

#12 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #27122: Add overhauled bridge support to API added

#13 Updated by Dru Lavigne about 1 year ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.3 to N/A
  • Reason for Closing set to Not to be fixed

Nik: the work to resolve this issue will occur on #27122 (linked as a related ticket).

Also available in: Atom PDF