Project

General

Profile

Bug #24457

Avatar?id=14398&size=22x22

Built-in Collection URL for jail templates is 404

Added by Stranded Camel over 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
Kris Moore
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Using FreeNAS-11.0-RC4 (ccc181927), which was upgraded over the original install, which was 11.0-RC3.

The built-in Collection URL for jails gives a 404 error. It's <http://download.freenas.org/latest/RELEASE/x64/jails&gt;.

needs to be updated to: http://download.freenas.org/jails/11/x64/jails


Related issues

Is duplicate of FreeNAS - Bug #24456: Built-in Collection URL for jail templates is 404Closed: Duplicate2017-06-09

History

#1 Updated by Stranded Camel over 3 years ago

  • Seen in changed from Unspecified to 11.0-RC4

#2 Updated by Brandon Schneider over 3 years ago

  • Assignee changed from Brandon Schneider to William Grzybowski

#3 Updated by William Grzybowski over 3 years ago

  • Status changed from Unscreened to Closed: User Config Issue

That URL gives 403 Forbidden, not 404 Not Found.

#4 Updated by William Grzybowski over 3 years ago

  • Is duplicate of Bug #24456: Built-in Collection URL for jail templates is 404 added

#5 Updated by Benjamin Carr over 3 years ago

  • Description updated (diff)
  • Target version set to 11.0-U1
  • Seen in changed from 11.0-RC4 to 11.0

This is seen in FreeNAS11-Release as well:

http://download.freenas.org/latest/RELEASE/x64/jails results in a404

needs to be updated to: http://download.freenas.org/jails/11/x64/

On next update a switch is needed to the correct repo.

This also fails silently (actually a few hundred lines of red text as it downloads the jail but can't write it) because of: https://bugs.freenas.org/issues/15705

#6 Updated by Dru Lavigne over 3 years ago

  • Status changed from Closed: User Config Issue to Unscreened

Looks like http://download.freenas.org/jails/11/x64/ is the winning URL.

#7 Updated by William Grzybowski over 3 years ago

  • Assignee changed from William Grzybowski to John Hixson

#8 Updated by Sean Vetter over 3 years ago

Benjamin Carr wrote:

This is seen in FreeNAS11-Release as well:

http://download.freenas.org/latest/RELEASE/x64/jails results in a404

needs to be updated to: http://download.freenas.org/jails/11/x64/

On next update a switch is needed to the correct repo.

This also fails silently (actually a few hundred lines of red text as it downloads the jail but can't write it) because of: https://bugs.freenas.org/issues/15705

The current collection URL works just fine. => http://download.freenas.org/latest/RELEASE/x64/jails

When you say you get a 404 that is because you are accessing it with a web browser. What error are you seeing
in freenas when you try to create a jail? The collection url is probably not the problem.

#9 Updated by John Hixson over 3 years ago

  • Assignee changed from John Hixson to Brandon Schneider

Brandon, since you own jails, giving this to you. You need to write a migration for this.

#10 Updated by Brandon Schneider over 3 years ago

  • Assignee changed from Brandon Schneider to Kris Moore

#11 Updated by Vaibhav Chauhan over 3 years ago

  • Target version changed from 11.0-U1 to 11.0-U2

#12 Updated by Vaibhav Chauhan about 3 years ago

  • Target version changed from 11.0-U2 to 11.0-U3

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 11.0-U3 to 11.1

#14 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to 46

VB: is this migration still needed, and if so, is it on track for 11.1?

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from 46 to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

I can't seem to replicate this issue here. The jails seem to download and deploy fine.

Also available in: Atom PDF