Project

General

Profile

Bug #24491

Fix traceback when disabling AD directory service

Added by survive - over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Important
Assignee:
John Hixson
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi guys,

I was disabling my AD directory service & got a traceback message. I have attached a debug file. Note this filer is an AD member, not running domain controller services.

-Will

History

#1 Updated by survive - over 1 year ago

  • File debug-filer-02-20170612200626.txz added

#2 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to John Hixson

#3 Updated by John Hixson over 1 year ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.0-U1

#4 Updated by John Hixson over 1 year ago

  • Status changed from Screened to 15

Can you reproduce? If so, I'd like to know what traceback you are getting. Can you please either take a screen shot or cut & paste the traceback into the ticket? Cut & paste is preferable since I can see the entire traceback.

#5 Updated by survive - over 1 year ago

  • File traceback.txt added

Hi John,

Yes, I can reproduce this. I get it both starting & stopping the AD service. I'm also getting the yellow alert warning me that "tried 10 attempts to recover service activedirectory".

Attached is the traceback & request details.

-Will

#6 Updated by John Hixson over 1 year ago

survive - wrote:

Hi John,

Yes, I can reproduce this. I get it both starting & stopping the AD service. I'm also getting the yellow alert warning me that "tried 10 attempts to recover service activedirectory".

Attached is the traceback & request details.

-Will

Looks like you got hit by a bug I've already fixed. Can you try the release to verify?

#7 Updated by survive - over 1 year ago

Hi John,

I updated to 11-RELEASE & while I can't seem to reproduce the traceback error anymore I was greeted by the blinking yellow warning light with the "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory" when I logged on.

I disabled the AD service to test, re-enabled it and got a second line "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory" message when I clicked on the warning light again.

So I cleared the warnings & checked the stoplight again & got 2 lines of "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory", clear those, refresh & when the clock ticked over I got 2 lines of "WARNING: June 14, 2017, 3:50 p.m. - tried 10 attempts to recover service activedirectory"

Is my AD service really trying to restart itself over ten times a minute?

-Will

#8 Updated by John Hixson over 1 year ago

  • Status changed from 15 to Screened

survive - wrote:

Hi John,

I updated to 11-RELEASE & while I can't seem to reproduce the traceback error anymore I was greeted by the blinking yellow warning light with the "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory" when I logged on.

I disabled the AD service to test, re-enabled it and got a second line "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory" message when I clicked on the warning light again.

So I cleared the warnings & checked the stoplight again & got 2 lines of "WARNING: June 14, 2017, 3:45 p.m. - tried 10 attempts to recover service activedirectory", clear those, refresh & when the clock ticked over I got 2 lines of "WARNING: June 14, 2017, 3:50 p.m. - tried 10 attempts to recover service activedirectory"

Is my AD service really trying to restart itself over ten times a minute?

-Will

The code that prints this out should probably not print this out unless it actually can't recover the service (assuming it needs recovering!). It just means it ran for a certain amount of times and then stopped, which is correct. The warning should probably go away ;-) I'll keep this bug open to indicate that.

#9 Updated by Vaibhav Chauhan over 1 year ago

  • Target version changed from 11.0-U1 to 11.0-U2

#10 Updated by Vaibhav Chauhan over 1 year ago

  • Target version changed from 11.0-U2 to 11.0-U3

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Seen in changed from Unspecified to N/A

#12 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Screened to 46

John - Still going to try and nuke this warning for -U3 or is this a 11.1 task?

#13 Updated by John Hixson over 1 year ago

  • Status changed from 46 to 15

Kris Moore wrote:

John - Still going to try and nuke this warning for -U3 or is this a 11.1 task?

Original isssue was fixed. Second issue is fixed in master but I'm hesitant to merge to U3 since it includes all the new async stuff. If I retarget for 11.1, it seems pointless since 11.1 will include the fix ;-) I can of course backport, but is it worth it? It's an annoyance for sure, but isn't breaking anything.

#14 Updated by John Hixson over 1 year ago

  • Target version changed from 11.0-U3 to 11.1

#15 Updated by Dru Lavigne over 1 year ago

  • Status changed from 15 to 46

John: in that case should this ticket be closed or set to resolved?

#16 Updated by John Hixson over 1 year ago

  • Status changed from 46 to 15

Dru Lavigne wrote:

John: in that case should this ticket be closed or set to resolved?

I leave this to you guys ;-) The issue is fixed, but can't directly be merged to stable without duplicating work (essentially a rewrite of fixes). If it is important enough, I can do that, otherwise, it will be in 11.1.

#17 Updated by Dru Lavigne over 1 year ago

  • Status changed from 15 to 46
  • Assignee changed from John Hixson to Kris Moore

Kris: what are your thoughts?

#18 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from 46 to Ready For Release
  • Assignee changed from Kris Moore to John Hixson
  • Priority changed from No priority to Important

Lets have this go into 11.1 as originally planned.

#19 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-filer-02-20170612200626.txz)

#20 Updated by Dru Lavigne over 1 year ago

  • Private changed from Yes to No

#21 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Traceback disabling AD directory service to Fix traceback when disabling AD directory service

#22 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#23 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#24 Updated by Nick Wolff about 1 year ago

  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Test passes

#25 Updated by Nick Wolff about 1 year ago

  • Needs QA changed from Yes to No

#26 Updated by Dru Lavigne 9 months ago

  • File deleted (traceback.txt)

Also available in: Atom PDF