Project

General

Profile

Bug #24562

Hyper-v guest requires legacy NIC present or wont boot.

Added by Grant Stokes over 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

see https://forums.freenas.org/index.php?threads/mountroot-prompt-when-using-hyper-v-vm.54456/

Hyper-V only boots when a legacy NIC is present, even though you use the proper nics to set it up. With this config, you can also only cold boot.

Generation 1,
Boot from bios
8GB memory
2 CPU
IDE system drive
Legacy NIC
Normal NIC

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore over 3 years ago

  • Category changed from 123 to 137
  • Assignee changed from Sean Fagan to Alexander Motin
  • Priority changed from No priority to Nice to have

Mav,

This is an odd one. Not sure if there's something in HEAD we can backport to fix this. Although recent sync up with stable/11 might have already brought fixes into play.

#2 Updated by Alexander Motin over 3 years ago

  • Status changed from Unscreened to Screened

I'll try to reproduce it.

#3 Updated by Alexander Motin over 3 years ago

  • Status changed from Screened to Investigation
  • Priority changed from Nice to have to Important

I was unable to reproduce this issue exactly with "Generation 1" VM ("Generation 2" reproduced the problem reliably for me), but I do see oddity in fact that da0 device is reported by the kernel after kernel tries to mount root file system. I am not sure what magic makes it still work, but I suspect it is just a race condition, what somehow makes added legacy NIC fix it for you. I'll continue my investigation later when time permit, but until that I can recommend you to try contacting Microsoft developers working on Hyper-V drivers for FreeBSD (Sepherosa Ziehau <>). You may also try to test it with some further FreeNAS nightly builds, which will include present FreeBSD 11.1-BETA code, but as I have told, I don't think situation is really fixed there.

#4 Updated by Grant Stokes about 3 years ago

Kris Moore wrote:

Mav,

This is an odd one. Not sure if there's something in HEAD we can backport to fix this. Although recent sync up with stable/11 might have already brought fixes into play.

I'd like too add that it starts every time if I choke it for resources, If I set the cpu relative weight to like 5%, it gets past the boot issue and I can turn up the performance again. is there a tunable or some way I can insert a thread.sleep into the process to allow the hard disk controller to come up first? I can only get it to work in generation 1 bios boot.

#5 Updated by Grant Stokes about 3 years ago

Also works with only 1 cpu attached.

#6 Updated by Grant Stokes about 3 years ago

This solved it for me. Now it starts every time with max RAM and "MAX POWER"!
https://forums.freenas.org/index.php?threads/workaround-semi-fix-for-mountroot-issues-with-9-3.26071/

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Investigation to Closed: Cannot reproduce
  • Target version set to N/A

Grant: I'm closing this one out as you found a solution.

Also available in: Atom PDF