Project

General

Profile

Bug #24736

iocage Crashplan plugin broken

Added by Andrew Evans about 3 years ago. Updated over 2 years ago.

Status:
Closed: Not To Be Fixed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have just done a fresh install of 11.0 release. Used iocage cli to install the Crashplan plugin which seemed go successfully.

Crashplan didn't seem to be running so I logged into the jail and checked the logs:

root@27a71f18-5465-47a9-902b-a1644fe8619e:/var/log/crashplan # less engine_error.log
Java HotSpot(TM) Client VM warning: Can't detect initial thread stack location - find_vma failed

root@27a71f18-5465-47a9-902b-a1644fe8619e:/var/log/crashplan # less engine_output.log
2017-06-20 07:09:52,416 ERROR Could not determine local host name java.net.UnknownHostException: 27a71f18-5465-47a9-902b-a1644fe8619e: 27a71f18-5465-47a9-902b-a1644fe8619e: Name or service not known
at java.net.InetAddress.getLocalHost(InetAddress.java:1505)
at org.apache.logging.log4j.core.util.NetUtils.getLocalHostname(NetUtils.java:47)
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:353)
at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:420)
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:138)
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:207)
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:41)
at org.apache.logging.log4j.LogManager.getContext(LogManager.java:160)
at com.code42.logging.C42LoggerConfig.reconfigure(C42LoggerConfig.java:279)
at com.code42.logging.C42LoggerConfig.bootstrap(C42LoggerConfig.java:70)
at com.code42.logging.C42LoggerConfig.<clinit>(C42LoggerConfig.java:38)
at com.code42.logging.LoggerFactory.<clinit>(LoggerFactory.java:12)
at com.backup42.service.CPService.<clinit>(CPService.java:278)
Caused by: java.net.UnknownHostException: 27a71f18-5465-47a9-902b-a1644fe8619e: Name or service not known
at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)
at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928)
at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323)
at java.net.InetAddress.getLocalHost(InetAddress.java:1500)
... 12 more

I tried the following to try and isolate and troubleshoot the issue:
  • Adding the hostname into /etc/hosts inside jail - no change
  • Installing Crashplan from ports on a fresh iocage jail added through cli - same issue
  • Installing Crashplan from ports on a fresh warden jail added through gui - works fine

So the issue seems to be something that iocage is doing.

History

#1 Updated by Brandon Schneider about 3 years ago

  • Status changed from Unscreened to Screened

#2 Updated by William Grzybowski almost 3 years ago

  • Target version set to 11.2-BETA1

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Screened to Closed: Not To Be Fixed
  • Target version changed from 11.2-BETA1 to N/A

We are deprecating support for crashplan since they will no longer be servicing home-users.

Also available in: Atom PDF