Project

General

Profile

Bug #24820

Update ixl(4) driver

Added by Nick K over 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
Middleware
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Errors as described in two other posts on prior versions of FreeNAS.
https://bugs.freenas.org/issues/21087
https://bugs.freenas.org/issues/9358

Jun 26 06:26:34 freenas ixl1: Malicious Driver Detection event 2 on TX queue 386, pf number 1
Jun 26 06:27:01 freenas ixl1: MDD TX event is for this function!WARNING: 192.168.13.26 (iqn.1998-01.com.vmware:jksn-vm-2-19df360d): connection error; dropping connection


Related issues

Related to FreeNAS - Bug #9358: network problem with intel x710 FreeNAS-9.3-STABLE-201504152200 Resolved2015-04-22
Related to FreeNAS - Bug #21087: Network driver problem with intel x710 FreeNAS-9.10.1-U4 (ec9a7d3)Closed: Third party to resolve2017-02-11
Related to FreeNAS - Bug #26135: 10GB intel X520/540 port issueClosed: Duplicate2017-10-10
Is duplicate of FreeNAS - Bug #25992: Malicious Driver Detection event 2 on TX queue 389, pf number 1Closed: Duplicate2017-09-27

Associated revisions

Revision 9de00136 (diff)
Added by Dru Lavigne about 1 year ago

Mention updated drivers.
Ticket: #24604
Ticket: #24820
Ticket: #25709

History

#1 Updated by Nick K over 1 year ago

  • File debug-freenas-20170626071056.txz added

#2 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Alexander Motin

#3 Updated by Nick K over 1 year ago

  • Seen in changed from Unspecified to 11.0

#4 Updated by Alexander Motin over 1 year ago

  • Related to Bug #9358: network problem with intel x710 FreeNAS-9.3-STABLE-201504152200 added

#5 Updated by Alexander Motin over 1 year ago

  • Related to Bug #21087: Network driver problem with intel x710 FreeNAS-9.10.1-U4 (ec9a7d3) added

#6 Updated by Alexander Motin over 1 year ago

  • Status changed from Unscreened to Investigation
  • Priority changed from No priority to Important

I am not sure we can do much here, since we are not developing this driver. I've written to Eric Joyner, FreeBSD committer from Intel asking about it.

#7 Updated by Alexander Motin over 1 year ago

  • Private changed from Yes to No

#8 Updated by Alexander Motin over 1 year ago

  • Status changed from Investigation to Fix In Progress
  • Target version set to 11.1

I was told that next NIC driver update already present in FreeBSD head supposed to fix it. Lets target it to 11.1.

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Fix In Progress to 46

Sasha: is there anything to fix here?

#10 Updated by Alexander Motin about 1 year ago

  • Status changed from 46 to Ready For Release

Present nightly builds already include 1.7.12-k driver version, recommended by Eric Joyner from Intel. It should be in 11.1.

#11 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-freenas-20170626071056.txz)

#12 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Malicious Driver Detection to Update ixl(4) driver

#13 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#14 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #25992: Malicious Driver Detection event 2 on TX queue 389, pf number 1 added

#15 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

#16 Updated by Dru Lavigne 12 months ago

  • Related to Bug #26135: 10GB intel X520/540 port issue added

#17 Updated by Nick Wolff 11 months ago

  • Needs QA changed from Yes to No
  • QA Status deleted (Not Tested)

Also available in: Atom PDF