Project

General

Profile

Bug #24866

Add proxy support when submitting debugs

Added by Carl-Daniel Hailfinger almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Submitting crash repots automaticayy fails because the proxy settings are ignored. My proxy logs show that no access whatsoever happened, whereas the network monitoring shows that the FreeNAS box tried to access the internet directly and the associated packets were dropped.

This is a regression from FreeNAS 9.10.

Associated revisions

Revision 52851df8 (diff)
Added by William Grzybowski almost 4 years ago

fix(middlewared): configure http proxy on start and on events Ticket: #24866

Revision c3cfefd4 (diff)
Added by William Grzybowski almost 4 years ago

fix(middlewared): configure http proxy on start and on events Ticket: #24866

Revision 8b785e57 (diff)
Added by William Grzybowski almost 4 years ago

fix(middlewared): configure http proxy on start and on events Ticket: #24866 (cherry picked from commit c3cfefd4e5205cdbbff972e163423f28d077a858)

Revision 8da2d9da (diff)
Added by William Grzybowski almost 4 years ago

fix(middlewared): configure http proxy on start and on events Ticket: #24866

Revision ed71c17c (diff)
Added by William Grzybowski over 3 years ago

fix(middlewared): configure http proxy on start and on events Ticket: #24866 (cherry picked from commit c3cfefd4e5205cdbbff972e163423f28d077a858)

History

#1 Updated by Carl-Daniel Hailfinger almost 4 years ago

[2017/06/28 07:12:56] (DEBUG) middlewared.logger.CrashReporting.report():84 - Sending a crash report...
[2017/06/28 07:12:56] (DEBUG) raven.base.Client.send_remote():635 - Sending message of length 4733 to https://sentry.ixsystems.com/api/2/store/
[2017/06/28 07:12:59] (ERROR) sentry.errors.uncaught._log_failed_submission():621 - ['URLError: <urlopen error timed out>', ' File "middlewared/main.py", line 163, in call_method', ' File "middlewared/main.py", line 580, in
call_method', ' File "middlewared/main.py", line 568, in _call', ' File "plugins/update.py", line 156, in get_trains', ' File "freenasOS/Configuration.py", line 1042, in AvailableTrains', ' File "freenasOS/Configuration.py", line 782, in TryGetNetworkFile', ' File "freenasOS/Configuration.py", line 756, in TryGetNetworkFile', ' File "urllib/request.py", line 526, in open', ' File "urllib/request.py", line 544, in _open', 'File "urllib/request.py", line 504, in _call_chain', ' File "urllib/request.py", line 1346, in http_open', ' File "urllib/request.py", line 1320, in do_open']

#2 Updated by William Grzybowski almost 4 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Expected
  • Target version set to 11.0-U2

#3 Updated by William Grzybowski almost 4 years ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from William Grzybowski to Suraj Ravichandran

#4 Updated by William Grzybowski almost 4 years ago

Note FIX branch differs from master commit because of conflicts.

#5 Updated by Carl-Daniel Hailfinger almost 4 years ago

Does that mean Bug #24865 is also fixed? And is there an easy way to test the fix (manual download)?

#6 Updated by William Grzybowski almost 4 years ago

Carl-Daniel Hailfinger wrote:

Does that mean Bug #24865 is also fixed? And is there an easy way to test the fix (manual download)?

The update not working part, yes. However they still need to fix it showing errors.

As far as test it, there isn't really a easy way. You could try the nightly image from tomorrow (but I wouldn't run that in production, and you cant downgrade from nightly to stable).

#7 Updated by Carl-Daniel Hailfinger almost 4 years ago

Thank you for fixing this, and thanks for the info. I'll wait until the next stable is out, and upgrade from CD.

#8 Updated by Suraj Ravichandran almost 4 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Suraj Ravichandran to William Grzybowski

LGTM, but I have not tested it myself so request that QA ensures this be tested

@Release Engineer, note that this was done before the new style of Release Engg. process took effect so you would need to treat this as an old re thing.

#9 Updated by Vaibhav Chauhan almost 4 years ago

  • Target version changed from 11.0-U2 to 11.0-U3

#10 Updated by Carl-Daniel Hailfinger almost 4 years ago

I applied the patch linked in this bug manually to my FreeNAS 11.0 installation and tested it. Downloads of updates through proxy are fixed with the patch. I haven't tested whether crash reports also go through the proxy, but the middleware patch seems to have fixed at least the update case.

https://bugs.freenas.org/projects/freenas/repository/revisions/8b785e5786ac7bf6f95edb4d97952d4d15358f84

#11 Updated by Vaibhav Chauhan over 3 years ago

please publish your changes in a PR which will be merged against stable branch, also please let us know here when you have PR ready.

#12 Updated by William Grzybowski over 3 years ago

Vaibhav Chauhan wrote:

please publish your changes in a PR which will be merged against stable branch, also please let us know here when you have PR ready.

There is a FIX branch, please use that.

#13 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed by Developer to 47

#14 Updated by Dru Lavigne over 3 years ago

  • Subject changed from Proxy is ignored when submitting crash reports to Add proxy support when submitting debugs

#15 Updated by Joe Maloney over 3 years ago

  • Status changed from 47 to Ready For Release
  • Needs QA changed from Yes to No
  • QA Status Test Passes added
  • QA Status deleted (Not Tested)
  • Setup a proxy.
  • Joined the freenas to the proxy.
  • Used tcpdump | grep 3128 to catch the output.

After doing the above ticket with debug was created https://bugs.freenas.org/issues/25732.

I can verify that the ticket was created, and that the traffic went through the proxy.

#16 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF