Project

General

Profile

Bug #24867

I get a Traceback error when I try to "check now" for Updates

Added by Bonnie Follweiler over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
Vaibhav Chauhan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have a Clean Installed TrueNAS-11.0-RC1 (a46e91b8b)
I went to Update and clicked Check Now and got a traceback error
Screenshots and a debug are provided

Associated revisions

Revision d29ff206 (diff)
Added by Sean Fagan over 4 years ago

Check the mtime of the update.conf file when returning information about it. Note that this is a bit of a big hammer to the problem, but it works. Ticket: #24867

Revision 019b72e0 (diff)
Added by Sean Fagan over 4 years ago

A slight tweak to handle the update.conf file going away Ticket: #24867

Revision 082d7750 (diff)
Added by Sean Fagan over 4 years ago

Check the mtime of the update.conf file when returning information about it. Note that this is a bit of a big hammer to the problem, but it works. Ticket: #24867

Revision daa23417 (diff)
Added by Sean Fagan over 4 years ago

A slight tweak to handle the update.conf file going away Ticket: #24867

History

#1 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Sean Fagan to Bonnie Follweiler

Something is very wrong with your system, and you do not have a manifest file.

Could you verify that by looking at /data/manifest? It should not exist if my hypothesis is correct.

Either that or it's not using the right update server.

#2 Updated by Bonnie Follweiler over 4 years ago

  • Assignee changed from Bonnie Follweiler to Sean Fagan

That VM with the clean install is unavailable so I just now did another one and the same thing happened
It is at 10.20.1.81
root:abcd1234

#3 Updated by Bonnie Follweiler over 4 years ago

11620

#4 Updated by Bonnie Follweiler over 4 years ago

11621

Also, I'm not sure if this pertains, or not, but the available update options (trains) looks like the following screenshot

#5 Updated by Sean Fagan over 4 years ago

  • Status changed from 15 to Closed: User Config Issue
  • Assignee changed from Sean Fagan to Bonnie Follweiler

The problem is that it is using the external update server, and there is no TrueNAS-11-STABLE train on that system.

Until TrueNAS-11-STABLE is released, the system needs to be configured to use the internal update server.

Back to you :).

#6 Updated by Bonnie Follweiler over 4 years ago

  • Category changed from 54 to 42
  • Status changed from Closed: User Config Issue to Unscreened
  • Assignee changed from Bonnie Follweiler to William Grzybowski

Sean Fagan confirmed the update server is now correct. He tried the upgrade from the CLI and it works correctly.
This appears to be a gui issue.

#7 Updated by Sean Fagan over 4 years ago

I think what's happening is that once the SystemConfiguration object is created, it doesn't reload the update.conf file. The middleware, I am guessing, keeps it around, so it never updates; the CLI creates it each time it runs.

#8 Updated by William Grzybowski over 4 years ago

  • Assignee changed from William Grzybowski to Sean Fagan

Seems like some freenasOS issue to me.

            update = CheckForUpdates(
                diff_handler=handler.diff_call,
                handler=handler.call,
                train=updateobj.get_train(),
            )

This is the call being made, how can the GUI ever cache SystemConfiguration if its not passed anywhere?

#9 Updated by Sean Fagan over 4 years ago

_system_config = None
def SystemConfiguration():
    global _system_config
    if _system_config is None:
        _system_config = Configuration()
    return _system_config

So as long as there is a single python process, it will keep it cached. The goal is to not keep loading the same files over and over again, since this may also result in network accesses.

#10 Updated by William Grzybowski over 4 years ago

Sounds like "Not To be Fixed" then.

#11 Updated by Sean Fagan over 4 years ago

  • Status changed from Unscreened to Investigation

Nah. I'm just trying to figure out the best way to handle the caching, while still not breaking anything else we want to have related to it.

#12 Updated by Sean Fagan over 4 years ago

  • Category changed from 42 to 54
  • Status changed from Investigation to Needs Developer Review

I've pushed branch FIX-24867. William, can you review it?

I didn't test with the UI, admittedly, but I started a python shell, imported the right things, edited the update.conf file, and printed out hte update server name before and after. I also tried removing the update.conf file while doing so.

#13 Updated by William Grzybowski over 4 years ago

  • Status changed from Needs Developer Review to Reviewed

I don't know enough of freenasOS to comment on the internals changes it may reflect but as far as the code added it looks correct to me.

#14 Updated by Sean Fagan over 4 years ago

commit:d29ff2063c3841a4ef02dca88b076cbade9dda01 and commit:019b72e04cbcfa3c293d6dffc2e39bad702a99fa into master.

#15 Updated by Sean Fagan over 4 years ago

  • Assignee changed from Sean Fagan to Vaibhav Chauhan

And branch FIX-STABLE-24867 off of freenas/11.0-stable

VB?

#16 Updated by Sean Fagan over 4 years ago

Oh, note that while this was filed against TrueNAS, it affects FreeNAS (since it's common code).

#17 Updated by William Grzybowski over 4 years ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from 54 to 1
  • Target version set to 11.0-U2
  • Seen in changed from TrueNAS 11.0-INTERNAL to 11.0

Do we need this in U1?

#18 Updated by Sean Fagan over 4 years ago

  • Priority changed from No priority to Expected

I don't think it's critical (I just set the priority I think it should have). In general, most customers won't be impacted by this at all, it's mostly our own testing that uses it.

#19 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Reviewed to Merged

I have merged the changes, I have 'Merged' them in as this branch was created before we formalized RelEng procedure.

#20 Updated by Bonnie Follweiler over 4 years ago

11811
11812

I upgraded to 11.0Internal-U2
The TrueNAS 11 train is not available in the train list and I get the trackback error
Screenshots are provided

#21 Updated by Bonnie Follweiler over 4 years ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes added
  • QA Status deleted (Test Fails)

Test Passes in FreeNAS-11-MASTER-201707200434 (7517445)

#22 Updated by Vaibhav Chauhan over 4 years ago

I cannot change the status to 'Resolved'

#23 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Merged to Resolved

#24 Updated by Dru Lavigne almost 4 years ago

  • File deleted (debug-truenas-20170628071252.tgz)

#25 Updated by Dru Lavigne almost 4 years ago

  • File deleted (debug-truenas-20170629103120.tgz)

Also available in: Atom PDF