Project

General

Profile

Bug #24891

LDAP with Kerberos does not generate a ticket when using TLS connection to Open Directory server on startup

Added by Claas Lisowski about 3 years ago. Updated almost 3 years ago.

Status:
Closed: Not Applicable
Priority:
Nice to have
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have configured to use LDAP with macOS Server running Open Directory.
Kerberos is configured too and generating a ticket as expected.
A restart of the FreeNAS server should show that a ticket is generated - that works only if no TLS connection is configured.

If the TLS connection to the Open Directory server is configured the ticket is generated after hitting the "save" button in the LDAP dialog but no ticket is generated after a reboot.

History

#1 Updated by John Hixson about 3 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.0-U2

#2 Updated by Vaibhav Chauhan about 3 years ago

  • Target version changed from 11.0-U2 to 11.0-U3

#3 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from Screened to 46

John - Any update here? Punt or close?

#4 Updated by John Hixson about 3 years ago

  • Status changed from 46 to Screened
  • Target version changed from 11.0-U3 to 11.1

Kris Moore wrote:

John - Any update here? Punt or close?

No updates at this time, I have to reproduce (which involves setting this up). Punting to 11.1.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#6 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Screened to 15

Claas: is this still an issue after updating to 11.1? If so, please attach a new debug from the updated system.

#7 Updated by Claas Lisowski almost 3 years ago

Dru Lavigne wrote:

Claas: is this still an issue after updating to 11.1? If so, please attach a new debug from the updated system.

Hi Dru,
I just tested this configuration on 11.1, the issue is not present anymore. The ticket can be closed.

#8 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Not Applicable
  • Target version changed from 11.1-U1 to N/A

Thanks for the update, Claas!

Also available in: Atom PDF