Project

General

Profile

Bug #24930

Unify dataset create/update code in API

Added by William Grzybowski about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description


Related issues

Is duplicate of FreeNAS - Feature #23626: REST API to update dataset attributesClosed: Duplicate2017-04-27

Associated revisions

Revision b9907fba
Added by William Grzybowski about 3 years ago

Merge pull request #218 from freenas/issues/24930 Unify dataset creation/update in GUI/API Ticket: #24930

History

#1 Updated by William Grzybowski about 3 years ago

  • Is duplicate of Feature #23626: REST API to update dataset attributes added

#2 Updated by William Grzybowski about 3 years ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from William Grzybowski to Suraj Ravichandran

#3 Updated by Suraj Ravichandran about 3 years ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Suraj Ravichandran to William Grzybowski
  • % Done changed from 0 to 100

Pr is reviewed and approved, have issued a jenkins retest on the PR since it was last tested 12 days ago and we have changed some stuff since then so it could not possibly hurt to do the same.

#4 Updated by William Grzybowski about 3 years ago

  • Status changed from Reviewed by Developer to Ready For Release

#5 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Unify dataset create/update code with the API to Unify dataset create/update code in API

#6 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.1 to 11.1-BETA1

#7 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Ready For Release to Resolved

#8 Updated by Joe Maloney almost 3 years ago

  • Needs QA changed from Yes to No
  • QA Status deleted (Not Tested)

Also available in: Atom PDF