Project

General

Profile

Bug #25035

Document zvol path length limitation

Added by Axel Giraud almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Warren Block
Category:
Documentation
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello !

We are using some virtualised FreeNAS installations (Build FreeNAS-11.0-RELEASE (a2dc21583)) on Dell servers and ESXi 6.5 hypervisors with enterprise SSDs on LSI 9271 IT-Mode HBAs passed-through to the FreeNAS VMs.
So far they have proven very dependable.

I successfully replicated a Dataset containing 2 ZVols by the semi-auto method via VPN from one server to another after creating a periodic snapshot.
On the primary (sending) site, those 2 ZVols serve as ISCSi extents in a vSphere environment flawlessly.

However, on the receiving site I can only use one of the two ZVols as an extent for iSCSI sharing, which works perfectly with ESXi (after cloning a snapshot and removing the Read-Only attribute.)
After I select the second ZVol in the drop-down menu for adding an extent in the iSCSI Sharing section, I get the following error message in the menu itself:
<< Zvol "zvol/tank2/MasterDR/xxx/xxxVMSystems211-clone-auto-20170705.1658-2m" does not exist >>

I also tried to mount the replicated ZVol directly without doing a snapshot, but I get the same error.

When I try to copy the ZVol by ZFS send | recv, I also get the following error:
<< cannot open 'zvol/tank2/MasterDR/xxx/xxxVMSystems211': dataset does not exist
cannot receive: failed to read from stream >>

Then I tried to directly replicate only the ZVol, which completed successfully, incrementally several time with with auto-snapshots. I got the same error.

The replications seem to succeed and the space used is visible in the Storage section of the GUI, but the systems keeps telling that the ZVol doesn't exist.

I also tried to set the zfs set volmode=geom on the device and reboot, without success.

Would anyone be able to share some hints or ideas on where to look ?

Many thanks !

ZVol_Creation_Error.jpg (224 KB) ZVol_Creation_Error.jpg Axel Giraud, 07/06/2017 10:52 PM
11701

Associated revisions

Revision 7ba85967 (diff)
Added by Warren Block over 3 years ago

Note 63-character path length limit in relation to zvol name. Ticket: #25035

History

#1 Updated by Dru Lavigne almost 4 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Private changed from No to Yes

#2 Updated by Alexander Motin almost 4 years ago

  • Status changed from Unscreened to Closed: Not To Be Fixed
  • Priority changed from No priority to Important

The problem is very likely in the name length of the ZVOL device in devfs. The problem is that FreeBSD devfs has path length limitation of only 63 chars, and your name is obviously longer. Unfortunately it can't be easily changed. You may try to specify shorter name when cloning, and it should probably help.

#3 Updated by Dru Lavigne over 3 years ago

  • File deleted (fndebug.zip)

#4 Updated by Dru Lavigne over 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

#5 Updated by Dru Lavigne over 3 years ago

  • Subject changed from ZVol Replication issues to Document zvol path length limitation
  • Category changed from 129 to Documentation
  • Status changed from Closed: Not To Be Fixed to Resolved
  • Target version changed from N/A to 11.0-U3

#6 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Alexander Motin to Warren Block

Also available in: Atom PDF