Project

General

Profile

Bug #25036

Jails/Plugins do not auto-start after unlocking encrypted volume

Added by David Beitey about 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Joe Maloney
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After booting FreeNAS, my encrypted volume is locked. After going to Storage --> Volumes --> View Volumes and clicking to unlock the volume, I enter the passphrase and leave all services as enabled to restart after unlocking.

The volume unlocks, but all 6 jails I have which are set to "autostart" remain stopped. I can now manually restart jails one-by-one and they each start successfully.

Observed this happening in 11.0 but also now still present in 11.0-U1 (build aa82cc58d).

History

#1 Updated by Dru Lavigne about 3 years ago

  • Assignee changed from Release Council to Brandon Schneider
  • Target version set to 11.1

This should be fixed for the new jails implementation.

#2 Updated by Brandon Schneider about 3 years ago

  • Status changed from Unscreened to Screened

#3 Updated by Ben Whitman about 3 years ago

This was broken and fixed and broken again several times in the 9.3 and 9.10 trains. Really frustrating to see it happening again in 11.x

#4 Updated by Joe Maloney almost 3 years ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Brandon Schneider to Vladimir Vinogradenko
  • Priority changed from No priority to Important

#5 Updated by Vladimir Vinogradenko almost 3 years ago

  • Status changed from Unscreened to Screened

#6 Updated by Vladimir Vinogradenko almost 3 years ago

  • Status changed from Screened to 15

I was not able to repeat this with latest Nightly build. David, could you please attach a debug? (System -> Advanced -> Save Debug).

#7 Updated by David Beitey almost 3 years ago

Vladimir Vinogradenko wrote:

I was not able to repeat this with latest Nightly build. David, could you please attach a debug? (System -> Advanced -> Save Debug).

Neither can I now on either a fresh install of 11.1-RC1 or nightly from a few hours ago (FreeNAS-11-MASTER-201711020518), testing in a Virtualbox VM. That's good to know the if the issue is resolved but as Ben says above and as I've read in other bug reports, this issue has come and gone over time. Could some regression testing be put into place perhaps? Thanks.

#8 Updated by Vladimir Vinogradenko almost 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Vladimir Vinogradenko to Joe Maloney

#9 Updated by Jurgen Segaert almost 3 years ago

Does this ticket concern the old PBI-based jails or the new iocage-based jails? I just found that in 11.1-RC1 the "boot" property doesn't work for iocage-based jails either. I don't want to hijack this thread, but do not want to create duplicates either.

#10 Updated by David Beitey almost 3 years ago

Jurgen Segaert wrote:

Does this ticket concern the old PBI-based jails or the new iocage-based jails? I just found that in 11.1-RC1 the "boot" property doesn't work for iocage-based jails either. I don't want to hijack this thread, but do not want to create duplicates either.

My testing's only been with what gets created via the GUI so whatever the GUI was creating at the time is what I've used. My jails were created originally in 11.0-RC1's GUI (and then OS upgraded to 11.0-U1 etc). My testing today was with creating brand new jails in 11.1-RC1's GUI in a Virtualbox VM, testing that, and then upgrading the VM to nightly and testing again.

#11 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

David: I'll mark this as resolved. Please reopen if it happens again.

Also available in: Atom PDF