Project

General

Profile

Bug #25126

Fix "Upgrade Install" error

Added by Vaibhav Chauhan over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Bonnie Follweiler
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I am upgrading a VM from TN 9.10.2-u5 to TN 11.0rc1 using an iso. I took a screen shot of the error message and my VM set up

The upgrade does work if I select "Fresh Install".

this affects only TrueNAS but this is a common code so I will consider this to be part of FreeNAS-11.0-U2 release.

upgrade TrueNAS_11-2017-06-27-15-47-11.png (29.6 KB) upgrade TrueNAS_11-2017-06-27-15-47-11.png Bonnie Follweiler, 06/27/2017 01:12 PM
TN_Set_up-2017-06-27-16-15-11.png (95.9 KB) TN_Set_up-2017-06-27-16-15-11.png Bonnie Follweiler, 06/27/2017 01:16 PM
UpgradeTN11.0u2a.png (1.24 MB) UpgradeTN11.0u2a.png Bonnie Follweiler, 07/18/2017 08:15 AM
TNUpgrade110u2c.png (1.25 MB) TNUpgrade110u2c.png Bonnie Follweiler, 07/18/2017 08:15 AM
TNUpgrade110u2b.png (1.24 MB) TNUpgrade110u2b.png Bonnie Follweiler, 07/18/2017 08:15 AM
11762
11763
11808
11809
11810

History

#2 Updated by Bonnie Follweiler over 4 years ago

11808
11809
11810

Upgraded from TN 11.0Internal3-U1 to TN 100.0-U2
After I have selected to "Upgrade Install" the next screen asks me to select Install In New Boot Environment or Format The Boot Device.

If I select Install In New Boot Environment it starts to install but then gives this message in the console "The TrueNAS upgrade on ada0 has failed. Press enter to continue . . ."

If I select Format The Boot Device it installs.
I have provided screenshots

#3 Updated by Joe Maloney over 4 years ago

  • QA Status Test Fails added
  • QA Status deleted (Not Tested)

#4 Updated by Sean Fagan over 4 years ago

That's the gmirror issue. I thought that got fixed a long time ago (it even says it's merged).

#5 Updated by Vaibhav Chauhan over 4 years ago

I had cherry-picked the changes which were visible in redmine in #24846, (why did I cherry-pick ? there were some merge conflicts in the merge and the change was only one line, therefore I decided to cherry-pick instead of asking to recreate the FIX branch)

https://bugs.freenas.org/projects/truenas/repository/freenas/revisions/1a152f76d4a18c36a73204d819fe717f4e392579/

was that the only change that was suppose to go in or did I miss any ?

#6 Updated by Sean Fagan over 4 years ago

No, that was the only change, and as I recall Bonnie tested it as well and it worked.

#7 Updated by Sean Fagan over 4 years ago

"Upgraded from TN 11.0Internal3-U1 to TN 100.0-U2"

What is TN 100.0-U2?

#8 Updated by Sean Fagan over 4 years ago

Oh, I think I see the problem.

#9 Updated by Sean Fagan over 4 years ago

Hm, no, I cannot reproduce this with 11.0-INTERNAL8-U1. I used a VM with 2 32g SATA disks and one 20g SCSI disk. I did a fresh install with reformatting the disks, then an update install with reformatting, and then I did an update install creating a new BE. None of them failed.

#10 Updated by Sean Fagan over 4 years ago

  • Assignee changed from Sean Fagan to Bonnie Follweiler

Other than which versions you used, what sounds different?

#11 Updated by Sean Fagan over 4 years ago

I also tried with 11.0-INTERNAL3-U1, and still couldn't reproduce.

#13 Updated by Sean Fagan over 4 years ago

I'm confused. You said you did an ISO update, so why would doing an update through the GUI count?

Or are you saying the update worked (because that does appear to be TrueNAS-11.0-INTERNAL-U2)?

#14 Updated by Bonnie Follweiler over 4 years ago

Sorry for the confusion.
It will update if I select "Format The Boot Device" when I use the iso to update, which is how that one got updated.
If I, instead, choose "New Boot Environment" it looks like it's going to upgrade and then give the message "The TrueNAS upgrade on ada0 has failed. Press enter to continue . . ." and doesn't upgrade

To reproduce this Upgrade using the iso:
Click the TrueNAS Installer to start the upgrade
Choose"Install/Upgrade"
Select your boot drive (in my case it is ada0)
Choose "Upgrade Install"
Choose "Install in new boot environment"
Click "Yes" to proceed with the update
<It starts to install base-os (1 of 5)>
It goes to Installing TrueNASUI (5 of 5) give a gmirror: Can't store metadata on ada0p3:operation not permitted
The TrueNAS upgrade on ada0p3 has failed. Press enter to continue . .
Goes back to the Install/Upgrade screen

#15 Updated by Bonnie Follweiler over 4 years ago

  • Assignee changed from Bonnie Follweiler to Sean Fagan

#16 Updated by Sean Fagan over 4 years ago

  • Assignee changed from Sean Fagan to Bonnie Follweiler

Okay, I've tried a bunch of different combinations, and I still cannot reproduce this.

With TrueNAS 11.0-INTERNAL3-U1, I have tried:
  1. 2x32g SATA, 1x20g SCSI, and
  2. 1x32g SATA, 2x20g SCSI

For those, I have installed, from scratch, 11.0-INTERNAL3-U1, and then I have done an upgrade install, selecting Update Install, with Create New Boot Environment.

I have had nothing but successful updates.

I even let the last install go all the way to booting, logged into the UI, created a storage pool, and then rebooted. Still no issues with upgrading.

Note that I am using VMWare Fusion on a Mac for my VM, but that should not -- has not in my experience -- result in any behavioural differences w.r.t. the GEOM code.

The error message you are reporting, at that stage, happens when it is attempting to make the mirrored swap on the boot devices. (I believe. Since I can't reproduce it, I can't be positive of that, but there is only one place in the code that attempts to create a mirror, and that's it.)

I just tried again. Still cannot reproduce this.

#17 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

I was able to confirm this on Bonnie's box, and came up with a fix. Issue is that we don't need to re-create swap when doing an install into a BE, since the swap partition already exists. Fix incoming.

#19 Updated by Vaibhav Chauhan over 4 years ago

For some reason I can't change the status to wip, also are we treating this as a blocker for u2 ?

#20 Avatar?id=14398&size=24x24 Updated by Kris Moore over 4 years ago

It impacts TN only, so I made a new ticket #25211

#21 Updated by Bonnie Follweiler over 4 years ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes added
  • QA Status deleted (Test Fails)

Retest Passes now with latest Internal, FreeNAS 11.0-624

#22 Updated by Vaibhav Chauhan over 4 years ago

I cannot change the status to 'Resolved'

#23 Updated by Vaibhav Chauhan over 4 years ago

  • Status changed from Merged to Resolved

Also available in: Atom PDF