Project

General

Profile

Feature #25131

Interrupt fixes for Windows installations within VMs

Added by John Mcdonald about 2 years ago. Updated about 1 year ago.

Status:
Done
Priority:
Important
Assignee:
Marcelo Araujo
Category:
OS
Target version:
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

AMD A8-7670k (Godavari)
16GB of ram


Description

Preface: A bit new to freenas, but have a general idea what I'm doing

https://forums.freenas.org/index.php?threads/freenas-11-windows-10-vm-not-loading-iso-past-logo.55388/

This seems to be an issue, specifically with AMD and bhyve UEFI. Supposedly this is fixed in bhyve on FreeBSD 12. It appears to be some sort of issue with older drivers that didn't get updated/backported properly and are now broken. I would post logs, but there are none, which is the most frustrating part.

Screen Shot 2017-12-15 at 20.58.11.png (2.61 MB) Screen Shot 2017-12-15 at 20.58.11.png Roland Buczyński, 12/15/2017 11:58 AM
13406

Associated revisions

Revision abdc0356 (diff)
Added by Marcelo Araujo over 1 year ago

- Import revision r329320: post LAPIC interrupts using event
injection rather than virtual interrupts.

Ticket: #25131

Revision abdc0356 (diff)
Added by Marcelo Araujo over 1 year ago

- Import revision r329320: post LAPIC interrupts using event
injection rather than virtual interrupts.

Ticket: #25131

Revision f46e5a26 (diff)
Added by Marcelo Araujo over 1 year ago

- Import revision r329320: post LAPIC interrupts using event
injection rather than virtual interrupts.

Ticket: #25131

Revision f46e5a26 (diff)
Added by Marcelo Araujo over 1 year ago

- Import revision r329320: post LAPIC interrupts using event
injection rather than virtual interrupts.

Ticket: #25131

History

#1 Updated by Dru Lavigne about 2 years ago

  • Tracker changed from Bug to Feature
  • Category changed from 38 to 129
  • Assignee changed from Release Council to Alexander Motin

Sasha: is this something that is possible to backport or is it tied into the 12 kernel?

#2 Updated by John Mcdonald about 2 years ago

Dru Lavigne wrote:

Sasha: is this something that is possible to backport or is it tied into the 12 kernel?

I believe it's possible to backport. I spent a good number of hours reading through countless threads on the matter, and supposedly a fix was backported from FreeBSD 11 to freenas 10 to fix it in that release. Now the same issue is occurring in freenas 11. From what I gather, the sole issue lies in the Bhyve UEFI firmware needing an update (and that whatever update made it's way into freenas 10 never made it into freenas 11, possibly caused by freenas 11 having started before the fix was put into FreeBSD 11, at least that's my theory).

#3 Updated by Alexander Motin almost 2 years ago

  • Status changed from Unscreened to 15
  • Priority changed from No priority to Important
  • Target version set to 11.1

I've found few bhyve commits in FreeBSD head not merged to 11, which fixed legacy interrupt routing, used now AFAIK only for e1000 NIC emulation. I haven't found significant other significant difference, UEFI firmware was not updated in last year and seems identical. I've merged what I found, so you may try update to tomorrow nightly build to wee whether it help.

#4 Updated by Alexander Motin almost 2 years ago

Also nightly builds (further 11.1) include updated OS and ports that may bring in some things, if you think FreeBSD 11 update may help.

#5 Updated by John Mcdonald almost 2 years ago

Sorry for the slow reply, games happen. Unfortunately this NAS is in a production environment, so I cannot update to nightlies as I can't risk breaking things. Doubly unfortunately I do not have any other AMD machines available to test on.

for the e1000 NIC function, This particular issue happens regardless of configuration of any vm setting (cpu cores, ram, nic, etc...).

Apologies for lack of being able to test myself, I'll go poke the thread mentioned and see if someone there can do it.

#6 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 15 to 46

Sasha: what do you want to do with this ticket?

#7 Updated by Jeff Savage almost 2 years ago

I have a server that I can test on. It has an AMD Phenom II X965 Black Edition CPU. I'm also having similar issues. Windows 10 just shows the Windows 10 Logo and does nothing. I will update my server to nightly and reboot and see if that changes anything.

Edit: I'm back. I'm updated to nightly and Windows 10 and Windows Server 2016 at least both launch to setup. I'm installing Windows Server 2016 atm and will get back with you rather or not it was successfully installed or not.

~BetaLeaf

#8 Updated by Marcelo Araujo almost 2 years ago

  • Assignee changed from Alexander Motin to Marcelo Araujo

I'm gonna take a look on it, discussed with mav@

#9 Updated by Marcelo Araujo almost 2 years ago

Jeff Savage wrote:

I have a server that I can test on. It has an AMD Phenom II X965 Black Edition CPU. I'm also having similar issues. Windows 10 just shows the Windows 10 Logo and does nothing. I will update my server to nightly and reboot and see if that changes anything.

Edit: I'm back. I'm updated to nightly and Windows 10 and Windows Server 2016 at least both launch to setup. I'm installing Windows Server 2016 atm and will get back with you rather or not it was successfully installed or not.

~BetaLeaf

Do you have any update?

#10 Updated by Jeff Savage almost 2 years ago

Sorry for the delay.

Setup froze twice during install. It freezes on the "Getting files ready for installation" part.

#11 Updated by Dru Lavigne almost 2 years ago

  • Status changed from 46 to Screened

#12 Updated by Joshua Senkevech almost 2 years ago

Jeff Savage wrote:

Sorry for the delay.

Setup froze twice during install. It freezes on the "Getting files ready for installation" part.

Same- Ryzen Amd

#13 Updated by Joshua Senkevech almost 2 years ago

Maybe someone can try a single core in the nightly build?-- If the merge happens in 11.1 (?) I can test it.

#14 Updated by John Mcdonald almost 2 years ago

Marcelo Araujo wrote:

I'm gonna take a look on it, discussed with mav@

Would it be possible to bottle up the changes related to this and any dependencies into a manual update file? I have something I'd like to test.

#15 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Target version changed from 11.1 to 11.2-BETA1

#16 Updated by John Mcdonald over 1 year ago

Maybe this should just wait until freenas updates to FreeBSD 12, where this issue is fixed natively.

#17 Updated by Joshua Senkevech over 1 year ago

Well it should (be closer to working) once all the merges happen in 11.1, the problem might solve itself. I just can't test it until gets 11.1 stable. 11.2 might be a good point to revisit this issue.

#18 Updated by Roland Buczyński over 1 year ago

Why this has such low priority? :( this ticked is open now for 3 months

Windows vm's are really important and now they don't work on any AMD processor

#19 Updated by Tobias Müllauer over 1 year ago

Roland Buczyński wrote:

Why this has such low priority? :( this ticked is open now for 3 months

Windows vm's are really important and now they don't work on any AMD processor

I think not so many productions sites use server and in the environment. But it's a guess :)

#20 Updated by Roland Buczyński over 1 year ago

13406

I can confirm windows 10 working on my Ryzen 1700 on latest FreeNAS 11.1 :))))

#21 Updated by Dru Lavigne over 1 year ago

  • Status changed from Screened to 15

John: does 11.1 also resolve the issue for you?

#22 Updated by John Mcdonald over 1 year ago

Dru Lavigne wrote:

John: does 11.1 also resolve the issue for you?

Unfortunately this took so long that I decided to build a separate application server (which is probably not a bad idea, as I didn't spec my nas to do much more than nas and plex originally). I'd half forgotten about this post, so I never updated it to reflect this before now. I'll give it a poke to see if it works and post back.

#23 Updated by John Mcdonald over 1 year ago

Dru Lavigne wrote:

John: does 11.1 also resolve the issue for you?

Unfortunately this took so long that I decided to build a separate application server just 2 weeks ago (which is probably not a bad idea, as I didn't spec my nas to do much more than nas and plex originally). I'd half forgotten about this post, so I never updated it to reflect this before now. I'll give it a poke to see if it works and post back.

#24 Updated by Dru Lavigne over 1 year ago

Thanks John!

#25 Updated by John Mcdonald over 1 year ago

Dru Lavigne wrote:

John: does 11.1 also resolve the issue for you?

Unfortunately this took so long that I decided to build a separate application server just 2 weeks ago (which is probably not a bad idea, as I didn't spec my nas to do much more than nas and plex originally). I'd half forgotten about this post, so I never updated it to reflect this before now.

Edit: It appears to work, but due to it requiring copious amounts of ram, I am unable to complete the install (4 cpu's and 8GB of ram wasn't enough, and it was already forcing stuff to swap at that point).

#26 Updated by Dru Lavigne over 1 year ago

  • Status changed from 15 to Closed: Not Applicable
  • Target version changed from 11.2-BETA1 to N/A

John: the amount of RAM would also affect the ability to run VMs. I will close this ticket out as it seems most of the needed commits are in 11.1.

#27 Updated by Joshua Senkevech over 1 year ago

Roland, what settings did you use to install windows 10? I still can't seem to get past "Getting files ready for installation" or preparing to install, it freezes up at a random percentage.

-JS

#28 Updated by Roland Buczyński over 1 year ago

1 core
2gb of ram
UEFI as boot method
100GB zvol

Fresh iso from microsoft.com

Basicly everything is as stock as it can be

#29 Updated by Roland Buczyński over 1 year ago

I also don't have any RAM issues it works really nice on 2GB

#30 Updated by Joshua Senkevech over 1 year ago

I installed it just fine with 1 core. It seems to freeze completely when you install on 2 or more. Woot!

Edit: Someone might want to note this in the documentation or somewhere more permanent.

#31 Updated by Roland Buczyński over 1 year ago

In my case it works on 2 cores just fine

4 cores hangs on boot or on login screen

unusual core counts seem to perform better like 5 or 7 cores

Mabe reopen this issue?

#32 Updated by Tobias Müllauer over 1 year ago

hello. i am testing windows 10 now and i wondering how is yours CPU handling it?

#33 Updated by Roland Buczyński over 1 year ago

Ram is the only concern

CPU wise it works realy nice i have AMD Ryzen 1700 8 cores and 16 threads at 3,4Ghz

#34 Updated by Tobias Müllauer over 1 year ago

Roland Buczyński wrote:

Ram is the only concern

CPU wise it works realy nice i have AMD Ryzen 1700 8 cores and 16 threads at 3,4Ghz

my CPU is 100% when i am trying login first time. but my cpu is a bit old. =P
Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz
memory i dont have any problem with. i can run window 10 installation with 2gb.

#35 Updated by Roland Buczyński over 1 year ago

Oh you have an intel cpu so problems described here aren't affecting you

My VM is cpu intensive too when i'm login in because all user services are starting it's normal especially with your CPU that is quite old and has only 2 cores

#36 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Closed: Not Applicable to Fix In Progress
  • Target version changed from N/A to 11.3

Hi guys,

There is a patch under review that probably will fix the issue on AMD:
https://reviews.freebsd.org/D13780

Best,

#37 Updated by Dru Lavigne over 1 year ago

  • Status changed from Fix In Progress to Blocked
  • Reason for Blocked set to Dependent on a related task to be completed

#38 Updated by Roland Buczyński over 1 year ago

https://reviews.freebsd.org/D13780
This issue seems to be resolved

Any idea when we will see it in FreeNAS?

11.1-U2 possibly?

#39 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Blocked to In Progress

Roland Buczyński wrote:

https://reviews.freebsd.org/D13780
This issue seems to be resolved

Any idea when we will see it in FreeNAS?

11.1-U2 possibly?

Hello, I was waiting that patch land on FreeBSD Stable prior to merge it to FreeNAS, it landed at 15 of February! So, I'm afraid we won't see it on 11.1-U2, but probably I can manage to get it this week on Nightlies and then on 11.2-BETA*.

Best,

#40 Updated by Dru Lavigne over 1 year ago

  • Target version changed from 11.3 to 11.2-RC2

#41 Updated by Dru Lavigne over 1 year ago

  • Reason for Blocked deleted (Dependent on a related task to be completed)

#42 Updated by Marcelo Araujo over 1 year ago

  • Status changed from In Progress to Done
  • Target version changed from 11.2-RC2 to 11.3

#43 Updated by Marcelo Araujo over 1 year ago

  • Target version changed from 11.3 to 11.2-BETA1

OK, It was committed to stable, it is likely to be available at 11.2-BETA1. And soon in Nightlies too.

#44 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Freenas 11 bhyve UEFI cannot install windows to Interrupt fixes for Windows installations within VMs
  • Needs Doc changed from Yes to No

#45 Updated by Dru Lavigne over 1 year ago

#46 Updated by Dru Lavigne about 1 year ago

  • Status changed from Done to Ready for Testing

#47 Updated by Eric Turgeon about 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Severity set to New
  • Needs QA changed from Yes to No

From my 2170x machine it is working fine with FreeNAS-11.2-MASTER-201806191350 (4d34a765b) works fine!

#48 Updated by Dru Lavigne about 1 year ago

  • Status changed from Passed Testing to Done
  • Needs Merging changed from Yes to No

#49 Updated by Dru Lavigne about 1 year ago

  • Reason for Blocked deleted (Dependent on a related task to be completed)

Also available in: Atom PDF