Project

General

Profile

Bug #25245

Unable to create volume

Added by Andrew . about 3 years ago. Updated about 3 years ago.

Status:
Closed: User Config Issue
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When creating a volume I select from a device nothing is created and the following appeared in the console (see below). I get the same result regardless of browser (Microsoft Edge 38.14393.0.0/Microsoft EdgeHTML 14.14393, Chrome Version 59.0.3071.115 (Official Build) (64-bit) and Firefox 54.0.1 64-bit) on Windows 10 version 1607 build 14393.447.

This is while using Chrome:

Jul 20 15:36:31 topolhnas01mg.local notifier: swapoff: removing /dev/da2p1.eli as swap device
Jul 20 15:36:31 topolhnas01mg.local notifier: 32+0 records in
Jul 20 15:36:31 topolhnas01mg.local notifier: 32+0 records out
Jul 20 15:36:31 topolhnas01mg.local notifier: 33554432 bytes transferred in 0.042521 secs (789126128 bytes/sec)
Jul 20 15:36:31 topolhnas01mg.local notifier: dd: /dev/da1: end of device
Jul 20 15:36:31 topolhnas01mg.local notifier: 33+0 records in
Jul 20 15:36:31 topolhnas01mg.local notifier: 32+0 records out
Jul 20 15:36:31 topolhnas01mg.local notifier: 33554432 bytes transferred in 0.041707 secs (804526835 bytes/sec)
Jul 20 15:36:31 topolhnas01mg.local manage.py: [middleware.exceptions:37] [MiddlewareError: Unable to GPT format the disk "da1"]
Jul 20 15:36:32 topolhnas01mg.local GEOM_ELI: Device da2p1.eli destroyed.
Jul 20 15:36:32 topolhnas01mg.local GEOM_ELI: Detached da2p1.eli on last close.
Jul 20 15:36:32 topolhnas01mg.local http://topolhnas01mg.local./
Response: {
  "err": 1,
  "message": "project is not enabled"
}
Jul 20 15:36:32 topolhnas01mg.local manage.py: [rollbar:1097] Exception while posting item ApiError(u'project is not enabled',)
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/rollbar/__init__.py", line 1095, in send_payload
    _post_api('item/', payload, access_token=access_token)
  File "/usr/local/lib/python2.7/site-packages/rollbar/
_init__.py", line 1138, in post_api
    return _parse_response(path, SETTINGS['access_token'], payload, resp)
  File "/usr/local/lib/python2.7/site-packages/rollbar/
_init__.py", line 1274, in _parse_response
    raise ApiError(json_data.get('message') or 'Unknown error')
ApiError: project is not enabled


Related issues

Related to FreeNAS - Bug #25246: Use middleware to wipe disks on volume creationDone

History

#1 Updated by Andrew . about 3 years ago

  • File debug-topolhnas01mg-20170720161925.txz added

#2 Updated by Andrew . about 3 years ago

  • File 2017-07-20_bug.txt added

#3 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to 15

From your logs, there appears to be a problem with that disk or the controller:

Jul 20 15:30:46 topolhnas01mg.local GEOM: da1: the secondary GPT table is corrupt or invalid.
Jul 20 15:30:46 topolhnas01mg.local GEOM: da1: using the primary only -- recovery suggested.

Have you successfully used FreeNAS with these disks or controller before? Have the disks been formatted before? If so, which file system and operating system?

#4 Updated by Dru Lavigne about 3 years ago

  • Related to Bug #25246: Use middleware to wipe disks on volume creation added

#5 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to Closed: User Config Issue

#6 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-topolhnas01mg-20170720161925.txz)

#7 Updated by Dru Lavigne about 3 years ago

  • File deleted (2017-07-20_bug.txt)

#8 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

#9 Updated by Andrew . about 3 years ago

There was no previous/other file system on the device. I have a dozen other devices that are working fine. This was 'fixed' with a disk wipe (see Bug #25246). What I should have made clearer (sorry) was the way the error was handled. It seems that FreeNAS was spewing a bunch of information not related (especially the "Response ..." bit) as I couldn't tell if this was GUI/browser issue or a system/physical issue. Reporting, or even grepping, for references to the device would have been more helpful.

BTW, I suspect that the actual root cause was either ungraceful shutdown or upgrade then down grade of the host from ESXi 6.0 to ESXi 6.5 and back to ESXi 6.0 (this is a lab). As a dozen other devices were unaffected I am inclined to lean towards an ungraceful shutdown.

Also available in: Atom PDF