Project

General

Profile

Bug #25306

Cannot Upgrade from 9.10 to 11

Added by Aaron Reed about 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
William Grzybowski
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've tried using the bootable media and rec this error. Error: no such table: services_s3
I've tried using the GUI to upgrade and it hangs at 67%

History

#1 Updated by Aaron Reed about 3 years ago

  • File debug-freenas-20170726113720.txz added

#2 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to 15

It can take awhile for a major upgrade such as from 9.10 to 11.0 as the migration script needs to convert everything. How long did it stay at 67% and does it eventually finish is you wait longer?

Also, what is the output of this command: beadm status ?

#3 Updated by Aaron Reed about 3 years ago

Dru Lavigne wrote:

It can take awhile for a major upgrade such as from 9.10 to 11.0 as the migration script needs to convert everything. How long did it stay at 67% and does it eventually finish is you wait longer?

Also, what is the output of this command: beadm status ?

I let it run all night last night and tried several times today. It still doesn't explain why it also error out using the usb media.
The output of that command is below. Doesn't seem to be the right command to use status.

usage:
beadm activate <beName>
beadm create [-r] [-e nonActiveBe | -e beName@snapshot] <beName>/<beName@snapshot> [nickname]
beadm destroy [-F] <beName | beName@snapshot | nickname>
beadm list [-a] [-s] [-D] [-H]
beadm rename [-n] <origBeName> <newBeName>
beadm mount <beName> [mountpoint]
beadm { umount | unmount } [-f] <beName>

#4 Updated by Aaron Reed about 3 years ago

I did a beadm list
BE Active Mountpoint Space Created Nickname
default - - 11.2M 2017-02-24 01:26 default
Initial-Install - - 2.8M 2017-02-24 09:35 Initial-Install
Wizard-2017-02-24_09:38:26 - - 191.0K 2017-02-24 09:38 Wizard-2017-02-24_09:38:26
Wizard-2017-02-24_10:11:45 - - 344.0K 2017-02-24 10:11 Wizard-2017-02-24_10:11:45
9.10.2-U2 - - 135.3M 2017-03-06 23:44 9.10.2-U2
9.10.2-U3 - - 5.1M 2017-04-24 04:17 9.10.2-U3
9.10.2-U4 - - 641.6M 2017-05-30 16:10 9.10.2-U4
9.10.2-U4-1 - - 7.4M 2017-05-30 16:41 9.10.2-U4-1
Wizard-2017-06-05_17:41:50 - - 4.1M 2017-06-05 17:41 Wizard-2017-06-05_17:41:50
9.10.2-U5 - - 648.4M 2017-06-14 12:27 9.10.2-U5
default-20170724-204503 - - 741.0M 2017-07-24 16:45 default-20170724-204503
default-20170724-214324 - - 741.0M 2017-07-24 17:43 default-20170724-214324
9.10.2-U6 NR / 3.3G 2017-07-26 09:52 9.10.2-U6

#5 Updated by Aaron Reed about 3 years ago

I've also tried Firefox, Safari, and Chrome browsers.

#6 Updated by Aaron Reed about 3 years ago

I used a manual update in the GUI fyi.

#7 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Sean Fagan

#8 Updated by Sean Fagan about 3 years ago

  • Assignee changed from Sean Fagan to William Grzybowski

The error about s3 table is a migration error, which is William's area.

Normally this is caused by updating to a nightly train at some point, but I don't see that in the BE list. The GUI being hung at 67% isn't something I can diagnose here, I think.

I note that there are no downloads of updates in the debug.log files.

#9 Updated by William Grzybowski about 3 years ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

Where and when, exactly, are you seeing this error?

#10 Updated by Aaron Reed about 3 years ago

I used the automatic update in chrome and the update worked. Thanks guys for the fast responses but you can close this.

#11 Updated by William Grzybowski about 3 years ago

  • Status changed from 15 to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

#12 Updated by Aaron Reed about 3 years ago

  • % Done changed from 0 to 100

#13 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170726113720.txz)

#14 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

Also available in: Atom PDF