Project

General

Profile

Bug #25316

Avatar?id=14540&size=50x50 Avatar?id=14398&size=22x22

Update Iperf to 3-3.2

Added by James Majerus over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Kris Moore
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Installed version -- FreeNas# iperf --version iperf version 2.0.5 (08 Jul 2010) pthreads

Newer versions -- https://iperf.fr/iperf-download.php#freebsd


Related issues

Has duplicate FreeNAS - Feature #26857: Add iperf3 PortClosed: Duplicate2017-11-27

Associated revisions

Revision 9b2bca31 (diff)
Added by Kris Moore over 1 year ago

Add iperf3 to the build, keep the old one since they dont conflict

Ticket: #25316

History

#1 Avatar?id=14540&size=24x24 Updated by James Majerus over 1 year ago

  • File debug-Vault-20170726193258.txz added

#2 Avatar?id=14540&size=24x24 Updated by James Majerus over 1 year ago

  • File deleted (debug-Vault-20170726193258.txz)

#3 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Kris Moore
  • Private changed from Yes to No

Kris: looks like the latest port is 2.0.9.

#4 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.1
  • Seen in changed from Unspecified to 11.0-U2

Looks like the new port is iperf3. I'll see if we can switch.

#5 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

  • Status changed from Screened to Ready For Release

Added iperf3 to the build for 11.1

#6 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Old version of Iperf installed 2.0.5 to Update Iperf to 3-3.2

#7 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#8 Updated by Dru Lavigne about 1 year ago

Bonnie: I confirmed that both iperf versions 3.2 and 2.0.10 are present in 11-MASTER-201709211401-68e65a6.

#9 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#10 Updated by Bonnie Follweiler about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

Also available in: Atom PDF