Project

General

Profile

Bug #25358

Clarify tooltip for Domain Controller field

Added by Yuriy Lobanov over 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
Important
Assignee:
Timothy Moore II
Category:
Documentation
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

ATX Thermaltake Versa H21
Chieftec GPS-600A8 600W
mATX ASUS P10S-M
Pentium G4400 3,3GHz/3Mb
2133MHz
2 X 8Gb PC-17000 2133MHz ECC DDR4 UDIMM 2
2 X SEAGATE 2Tb (5900rpm, 64Mb,SATA III
2 X SanDisk Ultra USB 3.0 16 Gb

ChangeLog Required:
No

Description

При каждой перезагрузке на двух из пяти систем с FreeNAS появляются ошибки "Directory Users could not be retrieved: (-30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery". Ошибки стали появляться после апдейта с 9.10.2-U5 на v.11. Переустановка с нуля на 11.0-U2 не помогла - ошибки те же. Эти две системы отличаются по железу полностью - разные материнки, процессоры, память, загрузочные устройства. Общее - включена интеграция с Active Directory, предоставлен доступ по SMB (CIFS). В системе, на которую приложен debug, уровень Active Directory - Win2008R2.
После нескольких минут (5-10) сетевые диски становятся доступными.

FQDN.png (126 KB) FQDN.png Yuriy Lobanov, 07/30/2017 06:26 AM
11950

Related issues

Related to FreeNAS - Bug #24774: ActiveDirectory did not bind to the domainClosed: Not Applicable2017-06-22

History

#1 Updated by Yuriy Lobanov over 3 years ago

  • File debug-FREENAS-20170729175054.txz added

#2 Updated by Yuriy Lobanov over 3 years ago

  • File debug-FREENAS-20170729173526.tgz added

#3 Updated by Yuriy Lobanov over 3 years ago

  • File FreeNAS_error_v11_UD_FreshInstall2.txt added

#4 Updated by Yuriy Lobanov over 3 years ago

  • File debug-FREENAS-20170724160744.tgz added

#5 Updated by Yuriy Lobanov over 3 years ago

  • File FreeNAS_error_v11_U2.txt added

#6 Updated by Yuriy Lobanov over 3 years ago

  • Subject changed from Every reboot error: "Directory Users could not be retrieved: (-30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery" to Error every reboot : "Directory Users could not be retrieved: (-30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery"
  • Seen in changed from Unspecified to 11.0
  • Hardware Configuration updated (diff)

#7 Updated by Yuriy Lobanov over 3 years ago

  • Description updated (diff)

#8 Updated by Dru Lavigne over 3 years ago

  • Related to Bug #24774: ActiveDirectory did not bind to the domain added

#9 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Timur Bakeyev
  • Seen in changed from 11.0 to 11.0-U2

#10 Updated by Yuriy Lobanov over 3 years ago

  • Description updated (diff)

#11 Updated by Timur Bakeyev over 3 years ago

  • Status changed from Unscreened to 15
  • Target version set to 11.0-U3

Hi, Yuriy! I hope we can continue conversation in English, that would make it easier for the rest of the team.

You've dumped multiple issues into one ticket, which makes it's harder to address, but let's assume, that the one in the subject is most essential.

As a side note:

Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8035dd000 with size 0x1e000 to be written at offset 0xbe5000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8035dd000 with size 0x1e000 to be written at offset 0xbe5000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x806bd4000 with size 0x1e000 to be written at offset 0xde1000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x806bd4000 with size 0x1e000 to be written at offset 0xde1000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8161c5000 with size 0x1e000 to be written at offset 0x4760000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8161c5000 with size 0x1e000 to be written at offset 0x4760000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x817403000 with size 0x106000 to be written at offset 0x52c9000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x817403000 with size 0x106000 to be written at offset 0x52c9000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x817509000 with size 0x42000 to be written at offset 0x53cf000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x817509000 with size 0x42000 to be written at offset 0x53cf000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x81754b000 with size 0x42000 to be written at offset 0x5411000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x81754b000 with size 0x42000 to be written at offset 0x5411000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x81909b000 with size 0x106000 to be written at offset 0x54ec000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x81909b000 with size 0x106000 to be written at offset 0x54ec000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8191a1000 with size 0x42000 to be written at offset 0x55f2000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8191a1000 with size 0x42000 to be written at offset 0x55f2000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x819e24000 with size 0x106000 to be written at offset 0x583c000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x819e24000 with size 0x106000 to be written at offset 0x583c000 for process python3.6
Jul 29 17:30:06 FREENAS kernel: pid 216 (python3.6), uid 0: exited on signal 11 (core dumped)

This could be just very sophisticated core dump, but could be corrupted binary as well. See https://github.com/freebsd/freebsd/blob/master/sys/kern/imgact_elf.c. Also https://reviews.freebsd.org/D9233?id=24232

#12 Updated by Timur Bakeyev over 3 years ago

As for the main problem, please, read https://forums.freenas.org/index.php?threads/%D0%BF%D0%BE%D1%81%D0%BB%D0%B5-%D0%B0%D0%BF%D0%B3%D1%80%D0%B5%D0%B9%D0%B4%D0%B0-%D0%B4%D0%BE-freenas-11-0-u1-%D0%BF%D1%80%D0%BE%D0%B1%D0%BB%D0%B5%D0%BC%D1%8B-%D1%81-%D0%BA%D0%B8%D1%80%D0%B8%D0%BB%D0%BB%D0%B8%D1%86%D0%B5%D0%B9-%D0%B2-%D0%BD%D0%B0%D0%B7%D0%B2%D0%B0%D0%BD%D0%B8%D1%8F%D1%85-windows-smb.56188/

And apply the fix to rc.conf.local. That shouldn't fix your issue entirely, but should address certain problems with the user/group names in Cyrillic.

After applying the fix, please collect debug report again and in general, check, what is not working.

The problem you experience, seems, somehow connected with the presence of the Cyrillic(non-ASCII) usernames and groupnames in the AD. In our environment it's a bit hard to reproduce, but if nothing else would help - we'll try to.

#13 Updated by Yuriy Lobanov over 3 years ago

  • File debug-FREENAS-20170730070023.tgz added
  • File FreeNAS_error_2.txt added

1. I add string LANG = en_US.UTF-8 in file /conf/base/etc/rc.conf.local, but after reboot receive the same error - bsddb3.db.DBRunRecoveryError: (30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery - BDB0060 PANIC: fatal region error detected; run recovery')

See attached debug.

2. Error like "Jul 29 17:30:06 FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8035dd000 with size 0x1e000 to be written at offset 0xbe5000 for process python3.6"
i received only two times.

First log is attached.

3. Why in some lines timestamp in UTC, but not in UTC+2?

#14 Updated by Yuriy Lobanov over 3 years ago

Yes, some usernames and groupnames in the AD in Cyrillic(non-ASCII)

#15 Updated by Yuriy Lobanov over 3 years ago

  • File debug-freenas-20170730073105.tgz added

Other FreeNAS server with the same motheboard mATX ASUS P10S-M, same USB flash for system, but Core i3-6300 3,8GHz/4Mb and 32Gb PC-17000 2133MHz ECC DDR4 UDIMM

AD with usernames and groupnames in Cyrillic(non-ASCII), AD level windows Server 2003

No errors with "Directory Users could not be retrieved:"

See attached Debug

#16 Updated by Yuriy Lobanov over 3 years ago

I discovered "FREENAS kernel: Failed to fully fault in a core file segment at VA 0x8035dd000" appears at first (and only first) opening services after reboot.

See Bug #25360

#17 Updated by Yuriy Lobanov over 3 years ago

  • File FQDN.png added

Probably, the problem is solved?

When filling the Domain Controller field on the Active Directory tab, I used the FQDN, as indicated on the prompt (Screenshot attached), termserver.books.local, instead of the short name termserver, which is mentioned in the documentation. After specifying a short name, errors do not appear during the reboot.

Opening the Services tab does not lead to core dump.

Why does the slightly inaccurate filling of the field lead to such serious errors?
Probably, you need to clarify the hint about the field of the Domain Controller?

#18 Updated by Yuriy Lobanov over 3 years ago

  • File deleted (FQDN.png)

#19 Updated by Yuriy Lobanov over 3 years ago

11950

#20 Updated by Yuriy Lobanov about 3 years ago

I repeated the adjustment of the Domain Controller field on the second FreeNAS server, where there was the same problem with errors during the reboot.
Errors disappeared.

For me, the problem is solved.

#21 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Status changed from 15 to Closed: User Config Issue
  • Target version changed from 11.0-U3 to N/A

#22 Updated by Yuriy Lobanov about 3 years ago

  • File deleted (debug-FREENAS-20170729175054.txz)

#23 Updated by Yuriy Lobanov about 3 years ago

  • File deleted (debug-FREENAS-20170729173526.tgz)

#24 Updated by Yuriy Lobanov about 3 years ago

  • File deleted (debug-FREENAS-20170724160744.tgz)

#25 Updated by Yuriy Lobanov about 3 years ago

  • File deleted (debug-FREENAS-20170730070023.tgz)

#26 Updated by Yuriy Lobanov about 3 years ago

  • File deleted (debug-freenas-20170730073105.tgz)

#27 Updated by Timur Bakeyev about 3 years ago

  • Private changed from Yes to No

#28 Updated by Kristaps Dinvietis about 3 years ago

  • File DirectoryService.png added

same error for me after each restart.

Directory Users could not be retrieved: (-30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery -- BDB0060 PANIC: fatal region error detected; run recovery')

started receiving these errors after upgrade from from 9.10 to 11.0, changed boot environment back to 9.10 and errors disappeared. fresh 11.0 install with config import also shows this error. strange thing is that all seems to work properly.
as of directory service, i am using active directory with basic settings mode (DirectoryService.png).

#29 Updated by Dru Lavigne about 3 years ago

  • Status changed from Closed: User Config Issue to 15

Yuriy: please attach a system debug (System -> Advanced -> Save Debug). We'll mark this ticket private until a dev has a chance to review the debug.

#30 Updated by Yuriy Lobanov about 3 years ago

  • File debug-FREENAS-20170724160744.tgz added
  • File debug-FREENAS-20170907154450.tgz added

I sent two files. Old, when problems have appeared, and current. Now there are no problems, since I removed the FQDN name of the domain controller with .local and entered a short one.

#31 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Timur Bakeyev to Warren Block
  • Target version changed from N/A to 11.1

Warren: it looks like the tooltip for this field is incorrect (see comments 20 and 30). It wouldn't hurt to clarify the description in the Guide either.

#32 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-FREENAS-20170907154450.tgz)

#33 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-FREENAS-20170724160744.tgz)

#34 Updated by Dru Lavigne about 3 years ago

  • File deleted (FreeNAS_error_v11_UD_FreshInstall2.txt)

#35 Updated by Dru Lavigne about 3 years ago

  • File deleted (FreeNAS_error_v11_U2.txt)

#36 Updated by Dru Lavigne about 3 years ago

  • File deleted (FreeNAS_error_2.txt)

#37 Updated by Dru Lavigne about 3 years ago

  • File deleted (DirectoryService.png)

#38 Updated by Yuriy Lobanov about 3 years ago

The error probably arises, not from the full name of the domain controller, FQDN, but from use in the domain name .local, which is now forbidden in the Active Directory, but was previously recommended for the transition from Windows Server NT4 to Windows Server 2000.

Using .local is given by mdns to connect Apple Devices.

#39 Updated by Yuriy Lobanov about 3 years ago

See Bug #25360 message #16

#40 Updated by Warren Block about 3 years ago

  • Status changed from Unscreened to Screened

#41 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#42 Updated by Dru Lavigne almost 3 years ago

  • Category changed from 1 to Documentation
  • Target version changed from 11.1-U1 to 11.2-BETA1

This belongs in new UI tooltips.

#43 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Screened to Not Started
  • Assignee changed from Warren Block to Timothy Moore II

Tim: please work with Warren to ensure the new UI tooltip is correct.

#44 Updated by Timothy Moore II almost 3 years ago

  • Status changed from Not Started to In Progress
  • Priority changed from No priority to Important

#45 Updated by Dru Lavigne over 2 years ago

  • Subject changed from Error every reboot : "Directory Users could not be retrieved: (-30973, 'BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery" to Clarify tooltip for Domain Controller field

#46 Updated by Timothy Moore II over 2 years ago

  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • % Done changed from 0 to 100
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Opened PR #52 (https://github.com/freenas/freenas-docs/pull/52) in freenas-docs to adjust documentation for this field.
Added to PR #359 (https://github.com/freenas/webui/pull/359) in freenas/webui to adjust tooltip for the relevant field.

Merging these should resolve this ticket.

#47 Updated by Timothy Moore II over 2 years ago

  • Status changed from In Progress to Done

After discussing with Dru, marking this as "done".

#48 Updated by Dru Lavigne over 2 years ago

  • Needs QA changed from No to Yes

Also available in: Atom PDF