Project

General

Profile

Bug #2536

Too many entries in smartd.conf

Added by Dusan Lacko about 7 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Erin Clark
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Steps to reproduce:
1. Create a scheduled short smart test for a drive
2. Create a scheduled long smart test for the same drive
3. Enable smartd

Result:
smartd.conf contains two lines for the same drive. smartd reads this as two different drives and therefore all the smart attribute polling & temperature checking will happen twice.

You can check this by running "smartd -q showtests". For example, for my 5 drives with a daily short and monthly long test scheduled, the command displays "Monitoring 10 ATA and 0 SCSI devices". Also, if you lower the critical temperature threshold to trigger a warning, you will receive two emails per drive + two lines in syslog.

The proper way to do this is to have only one smartd.conf line per drive and put all scheduled tests for that drive into one -s directive (e.g. something like -s (O/../.././(00|06|12|18)|S/../.././01|L/../../6/03) )

History

#1 Updated by Craig Rodrigues almost 7 years ago

  • Assignee deleted (Anonymous)
  • Target version deleted (9.1.1-RELEASE)
  • Seen in set to

#2 Updated by Jordan Hubbard almost 7 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to Dusan Lacko

Is this still happening? I notice this is pretty old.

#3 Updated by Dusan Lacko almost 7 years ago

Yes, ix-smartd still creates one smartd.conf line per one system_smarttest record, instead of aggregating all test for one drive on one line.

#4 Updated by Dusan Lacko almost 7 years ago

  • Assignee changed from Dusan Lacko to Jordan Hubbard

#5 Updated by Jordan Hubbard over 5 years ago

  • Priority changed from Important to Nice to have

#6 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from Jordan Hubbard to Erin Clark
  • Target version set to 49
  • Seen in changed from to 9.2.1.3-RELEASE

How about now, Erin, with the changes to smartd.conf generation you've made?

#7 Updated by Erin Clark over 4 years ago

Yes please try with the current 9.3 and see if this is still happening. If not this issue will definitely be resolved with FreeNAS 10 since we are using our own task system for short/long tests. Rather than relying on smartd.conf and its hacky parser.

#8 Updated by Erin Clark over 4 years ago

  • Status changed from Screened to 15

#9 Updated by Erin Clark over 4 years ago

Did you ever test this with a current Freenas?

#10 Updated by Erin Clark about 4 years ago

  • Status changed from 15 to Resolved

Timing out, this should be fixed in current FreeNAS versions so if you haven't already upgraded, please try 9.10 and reopen the ticket if you are still having difficulty

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF