Project

General

Profile

Bug #25403

Restore zvol size warning

Added by Joshua Sirrine about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
TrueNAS - 11.0-U2
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Doing some internal testing I discovered that some warnings that are normally present don't exist anymore.

If you :

1. Try to resize a zvol that will make the zpool go >80% full after the refreservation is applied (applied when zvol is created), you get a warning with red text (see screenshot).
2. You should get a warning if you try to create a zvol that will, after allocating the space, would result in the zpool going over 80% full.

2017-08-01_17h30_15.jpg (91.8 KB) 2017-08-01_17h30_15.jpg Warning from 9.10.2-U5 Joshua Sirrine, 08/01/2017 06:07 PM
Screen Shot 2017-10-13 at 9.08.58 AM.png (48.8 KB) Screen Shot 2017-10-13 at 9.08.58 AM.png Bonnie Follweiler, 10/13/2017 06:09 AM
11966
12689

Associated revisions

Revision 54fa6ed9 (diff)
Added by William Grzybowski about 1 year ago

fix(gui): warning of zvol size in edit dialog

Ticket: #25403

Revision 46806212 (diff)
Added by William Grzybowski about 1 year ago

fix(gui): warning of zvol size in edit dialog

Ticket: #25403

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore about 1 year ago

  • Assignee changed from Release Council to William Grzybowski
  • Target version set to 11.0-U3

Over to William to investigate

#2 Updated by William Grzybowski about 1 year ago

  • Status changed from Untriaged to Closed: Cannot reproduce
  • Target version changed from 11.0-U3 to na

I will need more details on how to reproduce, because I cant: http://i.imgur.com/jXITzoP.png

#3 Updated by William Grzybowski about 1 year ago

  • Status changed from Closed: Cannot reproduce to Screened
  • Target version changed from na to 11.0-U3

Ok, I see now, this is for Edit zvol, not create.

#4 Updated by William Grzybowski about 1 year ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from 42 to 2
  • Priority changed from No priority to Important
  • Target version changed from 11.0-U3 to 11.0-U3

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from Screened to Ready For Release
  • Target version changed from 11.0-U3 to 11.1

#6 Updated by Dru Lavigne about 1 year ago

  • Subject changed from WebGUI warning doesn't exist in 11.0, but exists in 9.10.2-U5 to Restore zvol size warning

#7 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#8 Updated by Dru Lavigne about 1 year ago

  • Description updated (diff)

#9 Updated by Bonnie Follweiler about 1 year ago

12689

Test Passed in FreeNAS-11-MASTER-201710120511
Screenshot provided

#10 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF