Project

General

Profile

Bug #25427

Unable to import NTFS drive

Added by Liam Leonard over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

It is currently not possible to import an NTFS drive through SATA. After beginning import, a couple seconds to a minute passes and this error appears and the import never completes.

Aug  2 23:58:09 freenas /sockscopy: [sockscopy:316] Import of Volume /dev/ada2p2 encoutered the following error NamedTemporaryFile() got an unexpected keyword argument 'bufsize'

I saw this thread post: https://forums.freenas.org/index.php?threads/cannot-import-ntfs-hdd.56633/ yesterday, though it seems the OP never created a bug report so I'm doing it instead.

My setup is far more mundane compared to that thread, I've simply got an i3-6100 cpu, 8gb of ram, and a 4tb red for both source and destination during the transfer.

I apologize for any formatting mistakes, this would be my first bug report for FreeNAS.

ntfs import 1.png (272 KB) ntfs import 1.png Joe Maloney, 09/06/2017 06:01 AM
12391

Related issues

Related to FreeNAS - Bug #18715: NTFS Disk ImportClosed: Duplicate2016-11-04
Is duplicate of FreeNAS - Bug #24816: Specify "-o large" when mounting MSDOS filesystemsResolved2017-06-25

History

#1 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Release Council to Suraj Ravichandran
  • Seen in changed from Master - FreeNAS Nightlies to 11.0-U2

Suraj: not sure if this one is related to your other import disk ticket as it doesn't give a traceback, just an error.

#2 Updated by Suraj Ravichandran over 3 years ago

  • Category changed from 129 to Middleware
  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.0-U3

The whole thing (import disk feature) needs some love, i'll keep it in here for now and tag this ticket in my commits when I do make them

#3 Updated by Vijay Paul over 3 years ago

Hi there,

I am experiencing same issue when importing a MSDOS formatted USB drive in FreeNAS 11.0-U2:

Import of Volume Failed.

Reason Expecting value: line 1 column 1 (char 0) 

Traceback
Traceback (most recent call last):
File "./freenasUI/storage/views.py", line 350, in volimport
data = json.loads(get_import_progress_from_socket())
File "/usr/local/lib/python3.6/json/__init__.py", line 354, in loads
return _default_decoder.decode(s)
File "/usr/local/lib/python3.6/json/decoder.py", line 339, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/local/lib/python3.6/json/decoder.py", line 357, in raw_decode
raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
OK

Log since insering the USB drive.

root@freenas:/ # tail /var/log/messages
Aug  8 17:19:07 freenas umass1: <SanDisk Ultra Fit, class 0/0, rev 2.10/1.00, addr 3> on usbus6
Aug  8 17:19:07 freenas umass1:  SCSI over Bulk-Only; quirks = 0xc100
Aug  8 17:19:07 freenas umass1:8:1: Attached to scbus8
Aug  8 17:19:07 freenas da1 at umass-sim1 bus 1 scbus8 target 0 lun 0
Aug  8 17:19:07 freenas da1: <SanDisk Ultra Fit 1.00> Removable Direct Access SPC-4 SCSI device
Aug  8 17:19:07 freenas da1: Serial Number 4C530001030722120360
Aug  8 17:19:07 freenas da1: 40.000MB/s transfers
Aug  8 17:19:07 freenas da1: 118464MB (242614272 512 byte sectors)
Aug  8 17:19:07 freenas da1: quirks=0x2<NO_6_BYTE>
Aug  8 17:19:46 freenas /sockscopy: [sockscopy:316] Import of Volume /dev/da1p2 encoutered the following error NamedTemporaryFile() got an unexpected keyword argument 'bufsize'

Spec
Build FreeNAS-11.0-U2 (e417d8aa5)
Platform AMD A4-3300 APU with Radeon(tm) HD Graphics
Memory 7878MB

Thanks for your effort!

#4 Updated by Marcus Ball over 3 years ago

I've submitted a pull request on Github with a potential fix: https://github.com/freenas/freenas/pull/271

#5 Updated by Suraj Ravichandran over 3 years ago

Hi I have taken your PR in but this feature still needs more work so I am currently working on a rewrite.

Post moving to Python 3 the tempfile's api changed slightly and it became "buffering" instead of "bufsize".

Thank you for your effort on this @Marcus Ball.

#6 Updated by Dru Lavigne over 3 years ago

  • Assignee changed from Suraj Ravichandran to William Grzybowski
  • Target version changed from 11.0-U3 to 11.1

Suraj: punting to 11.1.

William: please load balance between Vladimir and Nikola.

#7 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to Ready For Release

The PR was merged. We will tackle rewrite in #24816

#8 Updated by Dru Lavigne over 3 years ago

#9 Updated by Carl-Daniel Hailfinger over 3 years ago

Will the PR also be part of 11.0-U3? Given that it's already in 11.1, it's a one-line 2to3 conversion fix and the code will crash otherwise, merging it for 11.0-U3 should be fairly safe.

#10 Updated by William Grzybowski over 3 years ago

  • Status changed from Ready For Release to Screened
  • Seen in changed from 11.0-U2 to 11.0-U3

#11 Updated by William Grzybowski over 3 years ago

  • Target version changed from 11.1 to 11.0-U3
  • Seen in changed from 11.0-U3 to 11.0-U2

#12 Updated by William Grzybowski over 3 years ago

  • Status changed from Screened to Ready For Release

#13 Updated by William Grzybowski over 3 years ago

  • Status changed from Ready For Release to Reviewed by Developer

#14 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Reviewed by Developer to 47
  • Assignee changed from William Grzybowski to Joe Maloney

#15 Updated by Joe Maloney over 3 years ago

  • File ntfs import 1.png ntfs import 1.png added
  • Status changed from 47 to Ready For Release
  • Needs QA changed from Yes to No
  • QA Status Test Passes added
  • QA Status deleted (Not Tested)
12391

root@bonniemini:/mnt/tanka/ntfs # ls
.hiberfil.sys.cdFc6T Intel Program Files (x86) System Volume Information
$Recycle.Bin PerfLogs ProgramData Users
Documents and Settings Program Files Recovery Windows
root@bonniemini:/mnt/tanka/ntfs #

Works as expected.

#16 Updated by William Grzybowski over 3 years ago

  • Assignee changed from Joe Maloney to William Grzybowski

#17 Updated by Vaibhav Chauhan over 3 years ago

  • Status changed from Ready For Release to Resolved

#18 Updated by Dru Lavigne over 3 years ago

  • Is duplicate of Bug #24816: Specify "-o large" when mounting MSDOS filesystems added

#19 Updated by Carl-Daniel Hailfinger over 3 years ago

While Bug #24816 may have been affected by this issue as well, it's not a duplicate. I can still reproduce Bug #24816 in 11.0-U3.

Also available in: Atom PDF