Project

General

Profile

Feature #25452

Add red warning when stopping a service

Added by Joshua Sirrine about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
Nesma Shah
Category:
GUI (new)
Estimated time:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

We have had a standing policy that if changes being applied would possibly cause a service interruption, we would give a big red screen with an "are you really sure?" type of question. Those don't seem to be working anymore as I just stopped SMB on accident and killed a transfer that was in progress.

This is a high priority and should be fixed in the next future release as customers regularly misclick (and support sometimes ends up clicking on the wrong thing due to Teamviewer lag).

2017-09-05_22h36_38.jpg (24.2 KB) 2017-09-05_22h36_38.jpg Joshua Sirrine, 09/05/2017 10:37 PM
12384

History

#1 Updated by Joshua Sirrine about 4 years ago

We can probably give this to Bartosz to work on.

#2 Updated by Dru Lavigne about 4 years ago

  • Status changed from Untriaged to Unscreened
  • Assignee changed from Release Council to William Grzybowski

William: didn't we recently get a similar ticket (or was that the zvol warning one)?

#3 Updated by William Grzybowski about 4 years ago

  • Status changed from Unscreened to 15

Dru Lavigne wrote:

William: didn't we recently get a similar ticket (or was that the zvol warning one)?

Not similar.

I dont remember of these warnings when stopping a service at all. Can you post a screenshot to remind me?

#4 Updated by Joshua Sirrine about 4 years ago

I'll try to get you one very soon. Things are going pretty badly for me and a customer now that 11.0's train has been pulled without any warning.

#5 Updated by Dru Lavigne about 4 years ago

Joshua: are you able to provide a screenshot for William? If not, we'll close out this ticket until it is reproducible.

#6 Updated by Joshua Sirrine about 4 years ago

12384

Here's one for iSCSI (the only system I have available for the test).

#7 Updated by William Grzybowski about 4 years ago

Then please test others because iSCSI is the only one known to be there a screen for it. Not SMB as you mentioned.

#8 Updated by Joshua Sirrine about 4 years ago

  • Tracker changed from Bug to Feature

OKay, so I tried this on 9.10.2-U5 as well as 9.10.1 and I cannot see the red warnings. So either it's not on those versions, or this was never added and me and other members of the team are remembering something else.

In any case, I think we should consider this as a feature request in light of the fact that we do this on iSCSI and nothing else. Ideally, it would be great if we could have something like iSCSI's warning, where it says "hey, you got X sessions of this service open, are you sure you want to stop this service anyway?" and let the server admin decide if they want to kill those sessions anyway.

I've changed it to a feature ticket now, but I'll need the dev team to decide if we are going to implement this, and if so at what version. Frankly, this is a relatively low priority item in my opinion since this either never existed, or hasn't been working for some time (or at least intermittently). So if it gets pushed to 2018 that seems reasonable to me.

#9 Updated by Dru Lavigne about 4 years ago

  • Project changed from TrueNAS to FreeNAS
  • Subject changed from When stopping a service on TN 11.0-U2 there is no longer the red warning that services will be disrupted... to Add red warning when stopping a service
  • Category changed from 42 to 2
  • Status changed from 15 to Unscreened
  • Target version changed from 11.0-U3 to 11.1

#10 Avatar?id=14398&size=24x24 Updated by Kris Moore about 4 years ago

  • Category changed from 2 to GUI (new)
  • Assignee changed from William Grzybowski to Anonymous
  • Priority changed from No priority to Important
  • Target version changed from 11.1 to 11.2-BETA1

I'm going to punt this over to the new UI for 11.2. I'm thinking we should put it both in FreeNAS and TrueNAS, just automatically have a warning popup with text indicating that active sessions will be killed when you are about to stop any service.

#11 Updated by Anonymous about 4 years ago

  • Assignee changed from Anonymous to Vaibhav Chauhan

#12 Updated by Vaibhav Chauhan almost 4 years ago

  • Status changed from Unscreened to Screened

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 4 years ago

  • Assignee changed from Vaibhav Chauhan to Nesma Shah

#14 Updated by Nesma Shah almost 4 years ago

  • Status changed from Screened to Ready For Release

#15 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Ready For Release to Needs Developer Review

#16 Updated by Nesma Shah almost 4 years ago

  • Assignee changed from Nesma Shah to Lola Yang

#17 Updated by Lola Yang almost 4 years ago

  • Status changed from Needs Developer Review to 15

Already merged to master by Kris

#18 Updated by Lola Yang almost 4 years ago

  • Assignee changed from Lola Yang to Nesma Shah

#19 Updated by Dru Lavigne almost 4 years ago

  • Status changed from 15 to Resolved
  • Target version changed from 11.2-BETA1 to Master - FreeNAS Nightlies

Also available in: Atom PDF