Project

General

Profile

Bug #25518

Prevent creation of duplicate vlan

Added by Bonnie Follweiler over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
TrueNAS - 11.0-U2
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Related projects 1 project

Description

This would be for FreeNAS and TrueNAS
I recreated it in TrueNAS-11.0-U2 (2d3b18b24)
This is a current customer's issue. Sam Fourman has further details, if needed.

To recreate:
Go to Network ->Vlan and create a vlan
create a second vlan with the exact same name/credentials

Go to Network ->Interfaces and edit one of the vlan's you just set up and save.

freenas-vlan.png (110 KB) freenas-vlan.png Joe Maloney, 11/15/2017 01:33 PM
truenas-vlan.png (111 KB) truenas-vlan.png Joe Maloney, 11/15/2017 01:33 PM
13064
13065

Associated revisions

Revision 98500789 (diff)
Added by William Grzybowski over 1 year ago

fix(gui): make sure one cant add duplicated vlan name/tag

Ticket: #25518

Revision 21ddee28 (diff)
Added by William Grzybowski over 1 year ago

fix(gui): make sure one cant add duplicated vlan name/tag

Ticket: #25518

History

#1 Updated by William Grzybowski over 1 year ago

  • Project changed from TrueNAS to FreeNAS
  • Subject changed from TrueNAS doesn't warn against, or block the ability, to create a duplicate Vlan to No warn against, or block the ability, to create a duplicate Vlan
  • Category changed from 585 to 2
  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Important
  • Target version set to 11.1

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Screened to Ready For Release

#3 Updated by Dru Lavigne over 1 year ago

  • Subject changed from No warn against, or block the ability, to create a duplicate Vlan to Prevent creation of duplicate vlan

#4 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#5 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#6 Updated by Bonnie Follweiler about 1 year ago

  • 1 added project (TrueNAS)

#7 Updated by Nick Wolff about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Test passes QA

Side comment about functionality/devil advocate. I can see reasons why people might use the same vlan on different interfaces(of course with different names) which this doesn't allow but I will chalk that option also being blocked as a design decision here not a bug.

#8 Updated by Joe Maloney about 1 year ago

13064
13065

This is currently not working in TrueNAS-11.0-U5-RC1 (c8d802e24). I am able to create multiple vlans with the same id for the same interface as shown in the screenshot. It works as expected with FreeNAS 11.1-RC1 as shown in the screenshot.

#9 Updated by William Grzybowski about 1 year ago

  • Status changed from Resolved to 15
  • QA Status Test Passes TrueNAS added
  • QA Status deleted (Test Fails TrueNAS)

Target version says 11.1.

This has not been backported to 11.0.

#10 Updated by William Grzybowski about 1 year ago

  • Status changed from 15 to Resolved

Also available in: Atom PDF