Project

General

Profile

Feature #25522

Add checkbox to enable time machine to home share

Added by T F about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
OS
Target version:
Estimated time:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

It would be helpful to be able to edit the parameters for the home share that is placed in afp.conf and/or be able to have a checkbox to enable Time Machine lock stealing on users' afp home shares.

https://forums.freenas.org/index.php?threads/time-machine-backups-via-afp-to-home-share.56852 re-quoted below

I've been trying to setup a FreeNAS 11 system to serve as a Time Machine server for multiple users/clients. All the forum threads that I've read have people either creating separate zfs targets for each user/client or creating 1 share and granting all users access to see it. Neither of this will work in my environment, so I'm trying to achieve the same setup I have on my old Debian Linux server running netatalk/afpd that is currently handling backups with this configuration:

~/ "home" cnidscheme:dbd options:usedots,upriv,tm,noadouble ea:ad

The above basically translates to each user has access to their home directory which is shared via netatalk/afpd and enables TM Lock Stealing which is required for Mac clients to be able to use the resulting shares for Time Machine.

I couldn't find a way to achieve this setup with the FreeNAS Web UI, but I was able to manually modify /etc/local/afpd.conf to add 1 line to the [Homes] section that does the job:

[Homes]
basedir regex = /path/to/home/dirs
home name = home
time machine = yes

Adding that last line and HUP'ing the afpd process does the trick. The problem is, anytime the AFP service is restarted the middleware wipes out my custom change which results in the home shares no longer being valid Time Machine destinations. I'm considering writing a script to watch the file, update it when necessary & HUP afpd ... but I was wondering if anyone else has either come across this issue or come across a similar issue and knows of a way to "fix" FreeNAS so manual changes to configuration files will persist. I attempted to modify the /conf/base/etc/local/afpd.conf & /conf/base/etc/local/afpd.conf.sample files hoping that was where the middleware was starting off but that doesn't seem to do the trick.

EDIT/TLDR: I guess the gist of what I'm interested in is if anyone knows how to customize the home share. I'm currently doing so from a non-standard/supported approach but would like to be able to set my own options on the home share in afpd.conf and the FreeNAS UI doesn't seem to provide a way to do this.

Associated revisions

Revision ed7dc3e2 (diff)
Added by William Grzybowski about 1 year ago

feat(gui): add checkbox to enable time machine to home share

Ticket: #25522

Revision 593fe42a (diff)
Added by William Grzybowski about 1 year ago

feat(gui): add checkbox to enable time machine to home share

Ticket: #25522

Revision d58c606b (diff)
Added by Dru Lavigne 12 months ago

Add Home Share Time Machine.
Ticket: #25522

History

#1 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to William Grzybowski

William: does it make sense to add an Auxiliary Parameters for afpd.conf or, alternately, to add a Time Machine checkbox that sets these settings?

#2 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.2-BETA1

#3 Updated by William Grzybowski about 1 year ago

  • Target version changed from 11.2-BETA1 to 11.1

So all you need is the "time machine = yes" added to homes? Would the suggested "Home Time Machine" checkbox to AFP do the trick?

#4 Updated by T F about 1 year ago

That would meet my current need. I left it open ended for that vs. (or in addition to) a freeform text field for other options thinking others might find that useful as well.

#5 Updated by William Grzybowski about 1 year ago

free form text field is a nice stop gap solution but a lot of times people shoot their own foots with it so I would like to avoid that if at all possible.

#6 Updated by William Grzybowski about 1 year ago

  • Status changed from Screened to Needs Developer Review
  • Assignee changed from William Grzybowski to Marcelo Araujo

#7 Updated by T F about 1 year ago

That makes sense. Thanks for the quick turnaround.

#8 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from Marcelo Araujo to William Grzybowski

lgtm!

#9 Updated by William Grzybowski about 1 year ago

  • Status changed from Reviewed by Developer to Ready For Release

#10 Updated by Dru Lavigne about 1 year ago

  • Subject changed from allow home share to be used for TimeMachine backups to Add checkbox to enable time machine to home share

#11 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#12 Updated by Bonnie Follweiler 12 months ago

12733

Test passed in FreeNAS-11-MASTER-201710180506
Screenshot provided

#13 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF