Project

General

Profile

Bug #25700

Add IPv6 support for VNC in VMs

Added by Luka Kovačič over 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

There is no IPv6 support for VNC, only IPv4 works.

Steps to reproduce:
(IPv4 Address of the FreeNAS server):5901 - Works in TigerVNC and in Remote Desktop Viewer
(IPv6 Address of the FreeNAS server):5901 - Does not work in TigerVNC and in Remote Desktop Viewer

IPv6 is configured on my server and I can access the server configuration GUI from the IPv6 address and I can also ping the server with ping6

Screenshots included:
- Screenshot of working GUI open in the browser
- Screenshot of working IPv4 connection to VNC in TigerVNC
- Screenshot of not working IPv6 connection error to VNC in TigerVNC

Ping output:
PING 2a00:ADDRESS HIDDEN:27e4(2a00:ADDRESS HIDDEN:27e4) 56 data bytes
64 bytes from 2a00:ADDRESS HIDDEN:27e4: icmp_seq=1 ttl=64 time=0.177 ms
64 bytes from 2a00:ADDRESS HIDDEN:27e4: icmp_seq=2 ttl=64 time=0.164 ms
64 bytes from 2a00:ADDRESS HIDDEN:27e4: icmp_seq=3 ttl=64 time=0.136 ms
64 bytes from 2a00:ADDRESS HIDDEN:27e4: icmp_seq=4 ttl=64 time=0.169 ms
^C
--- 2a00:ADDRESS HIDDEN:27e4 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3106ms
rtt min/avg/max/mdev = 0.136/0.161/0.177/0.020 ms

TigerVNC_IPv4.png (10.6 KB) TigerVNC_IPv4.png TigerVNC (IPv4 Address Used) Luka Kovačič, 08/27/2017 03:53 AM
TigerVNC.png (12.1 KB) TigerVNC.png TigerVNC (IPv6 Address Used) Luka Kovačič, 08/27/2017 03:53 AM
TigerVNC_IPv4_Connected.png (18.4 KB) TigerVNC_IPv4_Connected.png TigerVNC (CONNECTED IPv4 session) Luka Kovačič, 08/27/2017 03:53 AM
TigerVNC_refused.png (6.93 KB) TigerVNC_refused.png TigerVNC (Refused IPv6 CONNECTION) Luka Kovačič, 08/27/2017 03:53 AM
FreeNAS_GUI_IPv6.png (55.1 KB) FreeNAS_GUI_IPv6.png FreeNAS GUI (IPv6) Luka Kovačič, 08/27/2017 03:54 AM
12293
12294
12295
12296
12297

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Marcelo Araujo

Marcelo: I thought this feature is coming in 11.1 but could not find the ticket. PLease close as duplicate with the ticket # if there already is one.

#2 Updated by Luka Kovačič over 1 year ago

Dru Lavigne wrote:

Marcelo: I thought this feature is coming in 11.1 but could not find the ticket. PLease close as duplicate with the ticket # if there already is one.

Luka: I tried looking for the duplicate and I think it does not exist.

#3 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.2-BETA1

Dru Lavigne wrote:

Marcelo: I thought this feature is coming in 11.1 but could not find the ticket. PLease close as duplicate with the ticket # if there already is one.

Unfortunately bhyve RFB implementation doesn't support IPv6, however the new libhyve-remote supports IPv6 by default.

I'm working trying to integrate libhyve-remote first on FreeBSD upstream, in case I can't make it ready on FreeBSD for FreeNAS 11.2-RELEASE, I have a plan B to have it on FreeNAS targeting 11.2-RELEASE.

#4 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Screened to Fix In Progress

With the addition of libhyve-remote we will have IPv6 support out of box.

#5 Updated by Marcelo Araujo about 1 year ago

  • Status changed from Fix In Progress to Ready For Release
  • Target version changed from 11.2-BETA1 to 11.1

I added libhyve-remote and all the bits necessary to improve VNC server.
Python bits were reviewed by williamgr and C bits by kris.

#6 Updated by Dru Lavigne about 1 year ago

  • Subject changed from No IPv6 support for VNC in VMs to Add IPv6 support for VNC in VMs
  • Target version changed from 11.1 to 11.1-BETA1

#7 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#8 Updated by Nick Wolff about 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Test Fails)

Test Passes

#9 Updated by Dave R about 2 months ago

I came across this bug recently when searching to see if anyone other than myself was in need of IPv6 support for bhyve vnc consoles or had implemented it elsewhere. I've been running a patched version of bhyve for some time that implements this feature and recently submitted a patch on the FreeBSD bug tracker. The patch hasn't been committed yet presumably because of the 12-RELEASE activities going on, but hopefully it will land in FreeBSD soon and IPv6 VNC console support will not need to be implemented on you project using a wrapper lib.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232018

Also available in: Atom PDF