Project

General

Profile

Bug #25709

Update mps driver

Added by Olivier Faber about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

X10SDV-4C-7TP4F board with a SAS826TQ backplane (also tested without backplane, no difference)

ChangeLog Required:
No

Description

The LSI SAS2116 in a Supermicro X10SDV-4C-7TP4F won't recognise any disks. Bug also described in this topic:
https://forums.freenas.org/index.php?threads/supermicro-x10sdv-4c-7tp4f-with-onboard-sas-no-disks.57278/

The dmesg shows this:


root@freenas:~ # dmesg | grep mps
mps0: <Avago Technologies (LSI) SAS2116> port 0xe000-0xe0ff mem 0xfb5c0000-0xfb5c3fff,0xfb580000-0xfb5bffff irq 16 at device 0.0 on pci3
mps0: Firmware: 20.00.07.00, Driver: 21.01.00.00-fbsd
mps0: IOCCapabilities: 1285c<ScsiTaskFull,DiagTrace,SnapBuf,EEDP,TransRetry,EventReplay,HostDisc>
mps_mapping_enclosure_dev_status_change_event: enclosure with handle = 0x1 reported 0 slots
mps0: SAS Address for SATA device = a2984a22a7bdc971
mps0: SAS Address from SATA device = a2984a22a7bdc971
failure at /freenas-11-releng/freenas/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0011
mpssas_fw_work: failed to add device with handle 0x11
mps0: SAS Address for SATA device = a2984a1fc7cfb190
mps0: SAS Address from SATA device = a2984a1fc7cfb190
failure at /freenas-11-releng/freenas/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0012
mpssas_fw_work: failed to add device with handle 0x12
mps0: SAS Address for SATA device = a2984a23c6a7c587
mps0: SAS Address from SATA device = a2984a23c6a7c587
failure at /freenas-11-releng/freenas/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0013
mpssas_fw_work: failed to add device with handle 0x13
mps0: SAS Address for SATA device = a2984a26c5cfd174
mps0: SAS Address from SATA device = a2984a26c5cfd174
failure at /freenas-11-releng/freenas/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0014
mpssas_fw_work: failed to add device with handle 0x14

I tried with NAS4Free, and there it does work:


nas4free: ~# dmesg | grep mps
mps0: <Avago Technologies (LSI) SAS2116> port 0xe000-0xe0ff mem 0xfb5c0000-0xfb5c3fff,0xfb580000-0xfb5bffff irq 16 at device 0.0 on pci3
mps0: Firmware: 20.00.07.00, Driver: 21.02.00.00-fbsd
mps0: IOCCapabilities: 1285c<ScsiTaskFull,DiagTrace,SnapBuf,EEDP,TransRetry,EventReplay,HostDisc>
mps0: SAS Address for SATA device = a2984a22a7bdc971
mps0: SAS Address from SATA device = a2984a22a7bdc971
mps0: SAS Address for SATA device = a2984a1fc7cfb190
mps0: SAS Address from SATA device = a2984a1fc7cfb190
mps0: SAS Address for SATA device = a2984a23c6a7c587
mps0: SAS Address from SATA device = a2984a23c6a7c587
mps0: SAS Address for SATA device = a2984a26c5cfd174
mps0: SAS Address from SATA device = a2984a26c5cfd174
da1 at mps0 bus 0 scbus0 target 3 lun 0
da0 at mps0 bus 0 scbus0 target 0 lun 0
da2 at mps0 bus 0 scbus0 target 5 lun 0
da3 at mps0 bus 0 scbus0 target 10 lun 0

I also checked in 9.10.2-U6, same story:


[root@freenas] ~# dmesg | grep mps
mps0: <Avago Technologies (LSI) SAS2116> port 0xe000-0xe0ff mem 0xfb5c0000-0xfb5c3fff,0xfb580000-0xfb5bffff irq 16 at device 0.0 on pci2
mps0: Firmware: 20.00.07.00, Driver: 21.01.00.00-fbsd
mps0: IOCCapabilities: 1285c<ScsiTaskFull,DiagTrace,SnapBuf,EEDP,TransRetry,EventReplay,HostDisc>
mps_mapping_enclosure_dev_status_change_event: enclosure with handle = 0x1 reported 0 slots
mps0: SAS Address for SATA device = a2984a22a7bdc971
mps0: SAS Address from SATA device = a2984a22a7bdc971
failure at /freenas-9.10-releng/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0011
mpssas_fw_work: failed to add device with handle 0x11
mps0: SAS Address for SATA device = a2984a1fc7cfb190
mps0: SAS Address from SATA device = a2984a1fc7cfb190
failure at /freenas-9.10-releng/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0012
mpssas_fw_work: failed to add device with handle 0x12
mps0: SAS Address for SATA device = a2984a23c6a7c587
mps0: SAS Address from SATA device = a2984a23c6a7c587
failure at /freenas-9.10-releng/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0013
mpssas_fw_work: failed to add device with handle 0x13
mps0: SAS Address for SATA device = a2984a26c5cfd174
mps0: SAS Address from SATA device = a2984a26c5cfd174
failure at /freenas-9.10-releng/_BE/os/sys/dev/mps/mps_sas_lsi.c:675/mpssas_add_device()! Could not get ID for device with handle 0x0014
mpssas_fw_work: failed to add device with handle 0x14


Related issues

Is duplicate of FreeNAS - Bug #19880: Failed to add the device with handle 0x000e to persistent table because there is no free space availableClosed: Duplicate2016-12-29

Associated revisions

Revision 9de00136 (diff)
Added by Dru Lavigne about 1 year ago

Mention updated drivers.
Ticket: #24604
Ticket: #24820
Ticket: #25709

History

#1 Updated by Dru Lavigne about 1 year ago

  • Status changed from Unscreened to 15

Olivier: please attach a debug (System -> Advanced -> Save Debug) to assist the dev in diagnosing the issue. We'll mark the ticket as private until the debug has been reviewed.

#2 Updated by Olivier Faber about 1 year ago

  • File debug-freenas-20170829232212.tgz added

Dru Lavigne wrote:

Olivier: please attach a debug (System -> Advanced -> Save Debug) to assist the dev in diagnosing the issue. We'll mark the ticket as private until the debug has been reviewed.

Sure, here it is.

#3 Updated by Dru Lavigne about 1 year ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Private changed from No to Yes

#4 Updated by Alexander Motin about 1 year ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

Does the problem happen if disks are connected without the backplane directly to HBA? I'd suspect some enclosure firmware bug.

Can you try to update to nightly train to see whether it help? We are not developing the driver ourselves, and nightly version should probably include the same version as NAS4Free.

#5 Updated by Olivier Faber about 1 year ago

Alexander Motin wrote:

Does the problem happen if disks are connected without the backplane directly to HBA? I'd suspect some enclosure firmware bug.

Can you try to update to nightly train to see whether it help? We are not developing the driver ourselves, and nightly version should probably include the same version as NAS4Free.

I tried connecting the disk directly to the controller without the backplane, but that didnt make a difference. I also tried a totally different type of disk: no difference.
I'll try the nightly.

#6 Updated by Olivier Faber about 1 year ago

It works with the current nightly!

#7 Updated by Alexander Motin about 1 year ago

  • File deleted (debug-freenas-20170829232212.tgz)

#8 Updated by Alexander Motin about 1 year ago

  • Status changed from 15 to Ready For Release
  • Private changed from Yes to No

Thank you. Then I am closing this, since it will be the part of 11.1 release.

#9 Updated by Dru Lavigne about 1 year ago

  • Subject changed from LSI SAS2116 on Supermicro X10SDV-4C-7TP4F wont recognise disks to Update mps driver

#10 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #19880: Failed to add the device with handle 0x000e to persistent table because there is no free space available added

#11 Updated by Dru Lavigne about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#12 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

#13 Updated by Nick Wolff 11 months ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF