Project

General

Profile

Bug #25738

Bug 12380

Added by Charles Elliott about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

On my (bug) "Reported issues" page for bug 12380, the Subject category says: "Can't create a user account (Closed: User Config Issue)". That is NOT why that bug was closed. After one of the 9.3.X updates, my FreeNAS user account no longer worked. I spent hours trying to recreate both my Group and my account, all without success. After filing bug 12380. I was told, insultingly, to live with it, that users were never meant to create their own accounts on FreeNAS. Yet the Guide still contains instructions for creating a new Group and new user account.

I don't understand what is going on. I would prefer not to have to log in to FreeNAS from every computer using the root account. Is it possible to create user accounts on FreeNAS or not? If the answer is "Yes, user accounts are available on FreeNAS," what do you suggest?

History

#1 Updated by Charles Elliott about 3 years ago

  • File debug-FreeNAS-20170831070438.txz added

#2 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to 15

To clarify: do you want non-root accounts to log into the web UI? If so, that is not supported.

If you want users to login using SSH, you can manually create or import users for that purpose.

What exactly is not working?

#3 Updated by Charles Elliott about 3 years ago

  • Seen in changed from Unspecified to 9.10.2-U6

I will have to get back to you when I have some more time; it is 10:30 AM, I have been here since 6:00 AM, and still done no work but little details. I tried mapping a new drive to the FreeNAS from Windows 10, my main system, using my old FreeNAS account name and PW, but that did not work. But no one knows what the PW is on that account I have changed it so many times, and it has been well over a year since this was an issue. It does work with root as the user and its password.

If I can make time tonight, would you oppose deleting the user account and its group and starting afresh?

I installed 9.10.2-U6 last night, so I changed the "Seen in" from unspecified to 9.10.2-U6.

#4 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to Closed: Not Applicable
  • Target version set to N/A

This type of assistance is best suited to the forums where users can assist with your configuration. I'll close out this bug as there isn't a bug to report. If you find a bug as a result of your forum discussion, please open another bug that contains the details of the bug.

#5 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-FreeNAS-20170831070438.txz)

#6 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Closed: Not Applicable to Closed

Also available in: Atom PDF