Project

General

Profile

Bug #25753

(ada6:ata8:0:0:0): CAM status: Command timeout

Added by Michael Grobe about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi .. there a tons of CAMS messages into the log:

Zpool Status is clean; but System crashes (hang) regulary ==>

03:06:54 A380NAS (ada6:ata8:0:0:0): FLUSHCACHE. ACB: e7 00 00 00 00 40 00 00 00 00 00 00
Sep 2 03:06:54 A380NAS (ada6:ata8:0:0:0): CAM status: Command timeout
Sep 2 03:06:54 A380NAS (ada6:ata8:0:0:0): Retrying command
Sep 2 03:08:04 A380NAS ata8: timeout waiting to issue command
Sep 2 03:08:04 A380NAS ata8: error issuing WRITE_DMA command
Sep 2 03:08:04 A380NAS (ada6:ata8:0:0:0): WRITE_DMA. ACB: ca 00 80 42 c0 40 00 00 00 00 01 00
Sep 2 03:08:04 A380NAS (ada6:ata8:0:0:0): CAM status: Command timeout
Sep 2 03:08:04 A380NAS (ada6:ata8:0:0:0): Retrying command
Sep 2 03:08:05 A380NAS ata8: timeout waiting to issue command
Sep 2 03:08:05 A380NAS ata8: error issuing WRITE_DMA command
Sep 2 03:08:05 A380NAS (ada6:ata8:0:0:0): WRITE_DMA. ACB: ca 00 1a 07 c3 40 00 00 00 00 01 00
Sep 2 03:08:05 A380NAS (ada6:ata8:0:0:0): CAM status: Command timeout
Sep 2 03:08:05 A380NAS (ada6:ata8:0:0:0): Retrying command
Sep 2 03:58:00 A380NAS ata8: timeout waiting to issue command
Sep 2 03:58:00 A380NAS ata8: error issuing WRITE_DMA command
Sep 2 03:58:00 A380NAS (ada6:ata8:0:0:0): WRITE_DMA. ACB: ca 00 18 07 c3 40 00 00 00 00 01 00
Sep 2 03:58:00 A380NAS (ada6:ata8:0:0:0): CAM status: Command timeout
Sep 2 03:58:00 A380NAS (ada6:ata8:0:0:0): Retrying command
Sep 2 03:59:02 A380NAS (ada6:ata8:0:0:0): WRITE_DMA. ACB: ca 00 8d 36 c6 40 00 00 00 00 01 00
Sep 2 03:59:02 A380NAS (ada6:ata8:0:0:0): CAM status: Command timeout
Sep 2 03:59:02 A380NAS (ada6:ata8:0:0:0): Retrying command
Sep 2 04:39:22 A380NAS ata8: timeout waiting to issue comm

History

#1 Updated by Michael Grobe about 3 years ago

11.0-STABLE FreeBSD 11.0-STABLE #0 r313908+d7d07647f69(freenas/11.0-stable): Thu Jul 20 19:01:05 UTC 2017 root@gauntlet:/freenas-11-releng/freenas/_BE/objs/freenas-11-releng/freenas/_BE/os/sys/FreeNAS.amd64 amd64

Smartctl -a /dev/ada6

Error 2 occurred at disk power-on lifetime: 1707 hours (71 days + 3 hours)
When the command that caused the error occurred, the device was in an unknown state.

After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 59 03 7d 17 90 e0 Error: ABRT 3 sectors at LBA = 0x0090177d = 9443197
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
c8 00 08 78 17 90 e0 90 00:05:15.798 READ DMA
c8 00 08 70 17 90 e0 90 00:05:15.797 READ DMA
c8 00 08 68 17 90 e0 90 00:05:15.796 READ DMA
c8 00 80 68 17 90 e0 90 00:05:11.144 READ DMA
c8 00 80 e8 16 90 e0 90 00:05:11.140 READ DMA

Error 1 occurred at disk power-on lifetime: 1707 hours (71 days + 3 hours)
When the command that caused the error occurred, the device was in an unknown state.

After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
10 59 6b 7d 17 90 e0 Error: IDNF 107 sectors at LBA = 0x0090177d = 9443197
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
c8 00 80 68 17 90 e0 90 00:05:11.144 READ DMA
c8 00 80 e8 16 90 e0 90 00:05:11.140 READ DMA
c8 00 80 68 16 90 e0 90 00:05:11.136 READ DMA
c8 00 80 e8 15 90 e0 90 00:05:11.132 READ DMA
c8 00 40 a8 15 90 e0 90 00:05:11.129 READ DMA
SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
  1. 1 Short offline Completed without error 00% 12282 -
  2. 2 Short offline Completed without error 00% 12259 -
  3. 3 Short offline Completed without error 00% 12211 -
  4. 4 Short offline Completed without error 00% 12170 -
  5. 5 Short offline Completed without error 00% 12142 -
  6. 6 Short offline Completed without error 00% 12056 -
  7. 7 Short offline Completed without error 00% 12008 -
  8. 8 Short offline Completed without error 00% 11983 -
  9. 9 Short offline Completed without error 00% 11974 -
    #10 Short offline Completed without error 00% 11936 -
    #11 Short offline Completed without error 00% 11912 -
    #12 Short offline Completed without error 00% 11883 -
    #13 Short offline Completed without error 00% 11864 -
    #14 Short offline Completed without error 00% 11840 -
    #15 Short offline Completed without error 00% 11812 -
    #16 Short offline Completed without error 00% 11765 -
    #17 Short offline Completed without error 00% 11656 -
    #18 Short offline Completed without error 00% 11616 -
    #19 Short offline Completed without error 00% 11477 -
    #20 Short offline Completed without error 00% 11339 -
    #21 Short offline Completed without error 00% 11300 -

Selective Self-tests/Logging not supported

#2 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to Closed: Not Applicable
  • Target version set to N/A

Those messages are not a bug but are consistent with a hardware issue. Check for bad cabling, bad power, a bad backplane, or a bad disk. If you need assistance in pinning down the culprit, create a post at forums.freenas.org.

#3 Updated by Michael Grobe about 3 years ago

  • Private changed from No to Yes

11.0-STABLE FreeBSD 11.0-STABLE #0 r313908+d7d07647f69(freenas/11.0-stable): Thu Jul 20 19:01:05 UTC 2017 root@gauntlet:/freenas-11-releng/freenas/_BE/objs/freenas-11-releng/freenas/_BE/os/sys/FreeNAS.amd64 amd64

Smartctl -a /dev/ada6

Error 2 occurred at disk power-on lifetime: 1707 hours (71 days + 3 hours)
When the command that caused the error occurred, the device was in an unknown state.

After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
04 59 03 7d 17 90 e0 Error: ABRT 3 sectors at LBA = 0x0090177d = 9443197
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
c8 00 08 78 17 90 e0 90 00:05:15.798 READ DMA
c8 00 08 70 17 90 e0 90 00:05:15.797 READ DMA
c8 00 08 68 17 90 e0 90 00:05:15.796 READ DMA
c8 00 80 68 17 90 e0 90 00:05:11.144 READ DMA
c8 00 80 e8 16 90 e0 90 00:05:11.140 READ DMA

Error 1 occurred at disk power-on lifetime: 1707 hours (71 days + 3 hours)
When the command that caused the error occurred, the device was in an unknown state.

After command completion occurred, registers were:
ER ST SC SN CL CH DH
-- -- -- -- -- -- --
10 59 6b 7d 17 90 e0 Error: IDNF 107 sectors at LBA = 0x0090177d = 9443197
Commands leading to the command that caused the error were:
CR FR SC SN CL CH DH DC Powered_Up_Time Command/Feature_Name
-- -- -- -- -- -- -- -- ---------------- --------------------
c8 00 80 68 17 90 e0 90 00:05:11.144 READ DMA
c8 00 80 e8 16 90 e0 90 00:05:11.140 READ DMA
c8 00 80 68 16 90 e0 90 00:05:11.136 READ DMA
c8 00 80 e8 15 90 e0 90 00:05:11.132 READ DMA
c8 00 40 a8 15 90 e0 90 00:05:11.129 READ DMA
SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
  1. 1 Short offline Completed without error 00% 12282 -
  2. 2 Short offline Completed without error 00% 12259 -
  3. 3 Short offline Completed without error 00% 12211 -
  4. 4 Short offline Completed without error 00% 12170 -
  5. 5 Short offline Completed without error 00% 12142 -
  6. 6 Short offline Completed without error 00% 12056 -
  7. 7 Short offline Completed without error 00% 12008 -
  8. 8 Short offline Completed without error 00% 11983 -
  9. 9 Short offline Completed without error 00% 11974 -
    #10 Short offline Completed without error 00% 11936 -
    #11 Short offline Completed without error 00% 11912 -
    #12 Short offline Completed without error 00% 11883 -
    #13 Short offline Completed without error 00% 11864 -
    #14 Short offline Completed without error 00% 11840 -
    #15 Short offline Completed without error 00% 11812 -
    #16 Short offline Completed without error 00% 11765 -
    #17 Short offline Completed without error 00% 11656 -
    #18 Short offline Completed without error 00% 11616 -
    #19 Short offline Completed without error 00% 11477 -
    #20 Short offline Completed without error 00% 11339 -
    #21 Short offline Completed without error 00% 11300 -

Selective Self-tests/Logging not supported

#4 Updated by Michael Grobe about 3 years ago

Thanks 4 your answer.
I will check .. and yes .. maybe this disk needk to replaced asap.

Regards
Mike

#5 Updated by Michael Grobe about 3 years ago

problem solved.

I was a bad power dable on the Disk .. that's why the disk got timeouts.
After the replacing the power cable .. all error messages were gone

#6 Updated by Dru Lavigne about 3 years ago

Glad you were able to resolve your issue!

#7 Updated by Dru Lavigne about 3 years ago

  • Private changed from Yes to No

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Closed: Not Applicable to Closed

Also available in: Atom PDF