Project

General

Profile

Bug #25765

"Set permission recursively" dataset permission checkbox is not populating "Permission type" value

Added by Bartosz Prokop about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
John Hixson
Category:
GUI (new)
Target version:
Seen in:
Severity:
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm not sure what's the correct behavior for this but it looks like "Permission type" value is not populated recursively.
On the other hand it would be nice to have an option for making the automatic permission inheritance.

History

#1 Updated by Dru Lavigne about 3 years ago

  • Status changed from Untriaged to 15

Bartosz: to clarify, this is happening on the old GUI?

#2 Updated by Bartosz Prokop about 3 years ago

  • Target version set to 11.1
  • Seen in changed from 11.1 to 11.0

Dru,

Yes; The problem occurs on the old GUI.

#3 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to Unscreened
  • Assignee changed from Release Council to William Grzybowski

#4 Updated by William Grzybowski about 3 years ago

  • Assignee changed from William Grzybowski to John Hixson

As far as I can remember John did that work.

#5 Updated by John Hixson about 3 years ago

  • Status changed from Unscreened to 15

Bartosz Prokop wrote:

I'm not sure what's the correct behavior for this but it looks like "Permission type" value is not populated recursively.
On the other hand it would be nice to have an option for making the automatic permission inheritance.

Can you clarify what this even means? Can you provide an example/reproduction case? Can you state what the expected/desired behavior is?

#6 Updated by Bartosz Prokop about 3 years ago

"Permission type" like (Unix, Mac, Windows) are not populated to the child datasets when the "Set permission recursively"
is checked.
By "permission inheritance" I'm thinking about populating permissions to the newly created datasets automatically when appropriate option is checked (it's actually an idea from the TN client).

Bartosz

#7 Updated by Dru Lavigne about 3 years ago

  • Status changed from 15 to 46

John: does this give you the information that you need? Is there anything to fix here?

#8 Updated by John Hixson about 3 years ago

Bartosz Prokop wrote:

"Permission type" like (Unix, Mac, Windows) are not populated to the child datasets when the "Set permission recursively"
is checked.

Datasets are marked as one of these types, you cannot subdivide them. If you create a foo dataset with mount path /foo as a windows dataset, /foo and everything below it will be type windows. You can't create a foo/bar dataset as type unix or mac, and it live under a type windows dataset. What need for this exists, why would you do this? There are so many reasons why NOT to do this. If I'm to do anything, I would change how we mark a dataset as one of these types (currently uses a sentinel file) to storing it on the dataset itself.

By "permission inheritance" I'm thinking about populating permissions to the newly created datasets automatically when appropriate option is checked (it's actually an idea from the TN client).

When you apply permissions recursively , they are applied recursively ;-) As in the same permission is applied ... recursively. I am not understanding the request here ;-)

Bartosz

#9 Updated by John Hixson about 3 years ago

Dru Lavigne wrote:

John: does this give you the information that you need? Is there anything to fix here?

No, I have no idea what is wanted here ;-) I've commented as such above. To be fixed, I need to know what is broken first ;-)

#10 Updated by John Hixson about 3 years ago

  • Status changed from 46 to Screened

#11 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Target version changed from 11.1 to 11.1-U1

#12 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Screened to Closed: Not Applicable
  • Target version changed from 11.1-U1 to N/A

#13 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Closed: Not Applicable to Closed

Also available in: Atom PDF