Project

General

Profile

Bug #25786

collectd and statvfs still reporting no such file or dir after rep task comes in from prod system

Added by Dave Matthews about 3 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Intel(R) Pentium(R) CPU G4400 @ 3.30GHz
16gig mem
target disk 2.5tb used, 2.9tb free, 2 volume spanned, zfs

ChangeLog Required:
No

Description

Sep 6 11:04:52 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory

Replication errors on destination server.
freenas server source 9.10.2-u6, repnas server destination 11.0-u3. These are showing up on destination since 11.0-u2 upgrade from 9.10-u4. I just installed 11.0-u3 from 11.0-u2 on destination and still showing errors. Replication comes over ok. I can mount and view the clone. Errors repeat every 10 seconds. Really files up the screen with useless info.

Small sample:
Sep 6 11:06:32 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:06:42 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:06:52 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:02 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:12 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:22 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:32 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:42 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:07:52 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:08:02 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:08:12 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory
Sep 6 11:08:22 repnas collectd3045: statvfs(/mnt/repvol/freenas/s) failed: No such file or directory


Related issues

Is duplicate of FreeNAS - Bug #27399: collectd continues to spam system log and consoleClosed
Is duplicate of FreeNAS - Bug #26134: ZFS replication causes datasets to become unavailableClosed: Duplicate2017-10-09

History

#1 Updated by Dru Lavigne about 3 years ago

Dave: you can't see the duplicating ticket ATM as it still contains a user's debug (once the dev has finished with the debug the ticket will become visible). But this has been reported and is slated to be fixed with the 11.1 update.

#2 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version set to N/A

#3 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #27399: collectd continues to spam system log and console added

#4 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #26134: ZFS replication causes datasets to become unavailable added

Also available in: Atom PDF