Project

General

Profile

Bug #25830

Update Dojo Toolkit to 1.12.2

Added by Adam Westing about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Expected
Assignee:
William Grzybowski
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The legacy web gui typically fails to load for me under 11.0-U3 (fresh install). The chrome dev console shows a js error about 'decimalFormat', picture and log attached.

I believe this is some kind of race condition as I can sometimes load the page, maybe 1/10 times. And if I set chrome to simulate a "Fast 3G Network", then the gui will consistently load. I have not observed any such problems with the new gui.

2017-09-10-172351_1898x357_scrot.png (128 KB) 2017-09-10-172351_1898x357_scrot.png Screenshot of js error Adam Westing, 09/10/2017 03:25 PM
freenas1.JPG (59.4 KB) freenas1.JPG Sean Choquette, 09/20/2017 04:43 PM
Screen Shot 2017-10-30 at 1.10.27 PM.png (216 KB) Screen Shot 2017-10-30 at 1.10.27 PM.png Bonnie Follweiler, 10/30/2017 10:11 AM
Screen Shot 2017-10-30 at 1.07.37 PM.png (224 KB) Screen Shot 2017-10-30 at 1.07.37 PM.png Bonnie Follweiler, 10/30/2017 10:11 AM
12444
12511
12855
12856

Related issues

Is duplicate of FreeNAS - Bug #25979: Web UI Doesn't Load Properly: Uncaught TypeErrorClosed: Duplicate2017-09-26
Is duplicate of FreeNAS - Bug #26007: Old GUI is not loading correctly in Chrome.Closed: Duplicate2017-09-28
Is duplicate of FreeNAS - Bug #26410: Browser Access to FreeNASClosed2017-10-30
Is duplicate of FreeNAS - Bug #26151: cannot select "start on boot"Closed: Duplicate2017-10-11

Associated revisions

Revision 40eba835 (diff)
Added by Dru Lavigne about 1 year ago

Indicate new Dojo and iocage versions.
Ticket: #25318
Ticket: #25830

History

#1 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

I cannot reproduce that. Which browser version and what OS are you using?

#3 Updated by Sean Choquette about 1 year ago

12511

William Grzybowski wrote:

I cannot reproduce that. Which browser version and what OS are you using?

I am also having this error with
FreeNAS-9.10.2-U6 (561f0d7a1)

Google Chrome
Version 61.0.3163.91 (Official Build) (64-bit)
!!

#4 Updated by William Grzybowski about 1 year ago

Sean Choquette wrote:

William Grzybowski wrote:

I cannot reproduce that. Which browser version and what OS are you using?

I am also having this error with
FreeNAS-9.10.2-U6 (561f0d7a1)

Google Chrome
Version 61.0.3163.91 (Official Build) (64-bit)
!!

I am using the exact same and cant reproduce. Which OS?

#5 Updated by Sean Choquette about 1 year ago

William Grzybowski wrote:

Sean Choquette wrote:

William Grzybowski wrote:

I cannot reproduce that. Which browser version and what OS are you using?

I am also having this error with
FreeNAS-9.10.2-U6 (561f0d7a1)

Google Chrome
Version 61.0.3163.91 (Official Build) (64-bit)
!!

I am using the exact same and cant reproduce. Which OS?

Windows 10 pro 64
I also have chrome adblock and adblockplus extensions
Works fine on edge

#6 Updated by William Grzybowski about 1 year ago

Sean Choquette wrote:

William Grzybowski wrote:

Sean Choquette wrote:

William Grzybowski wrote:

I cannot reproduce that. Which browser version and what OS are you using?

I am also having this error with
FreeNAS-9.10.2-U6 (561f0d7a1)

Google Chrome
Version 61.0.3163.91 (Official Build) (64-bit)
!!

I am using the exact same and cant reproduce. Which OS?

Windows 10 pro 64
I also have chrome adblock and adblockplus extensions
Works fine on edge

Have you tried disabling these extensions?

#7 Updated by Adam Westing about 1 year ago

William Grzybowski wrote:

Sean Choquette wrote:

William Grzybowski wrote:

Sean Choquette wrote:

William Grzybowski wrote:

I cannot reproduce that. Which browser version and what OS are you using?

I am also having this error with
FreeNAS-9.10.2-U6 (561f0d7a1)

Google Chrome
Version 61.0.3163.91 (Official Build) (64-bit)
!!

I am using the exact same and cant reproduce. Which OS?

Windows 10 pro 64
I also have chrome adblock and adblockplus extensions
Works fine on edge

Have you tried disabling these extensions?

I'm on Arch Linux (kernel 4.12.13) with Chrome 61.0.3163.91. I have tried with and without extensions, the problem occurs either way.

#8 Updated by Anno Langen about 1 year ago

Seen in FreeNAS-9.3-STABLE-201605170422 from Chrome on Windows Version 61.0.3163.100 (Official Build) (64-bit)

The previously established way of working with freenas is completely broken this way. It started mysteriously from one week to the next. I am not sure what updated.

The problem does not happen with Opera.

dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8 Uncaught TypeError: Cannot read property 'decimalFormat' of undefined
at _7 (NumberTextBox.js?1a41efc2bcad7847c38347c1ff2b08c1:4)
at NumberTextBox.js?1a41efc2bcad7847c38347c1ff2b08c1:19
at _ce (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at _37 (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at _37 (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8
at _38 (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at _81 (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at _f6 (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)
at HTMLScriptElement._10b (dojo.js?cache=1a41efc2bcad7847c38347c1ff2b08c1:8)

#9 Updated by William Grzybowski about 1 year ago

This looks like some issue on Chrome to me. How come a 9.3 which always worked, suddenly stopped working?

#10 Updated by Eric Loewenthal about 1 year ago

Indeed, there have been several reports of Chrome behaving stupidly with the old GUI on the forums, lately. Other browsers have been behaving normally.

#11 Updated by William Grzybowski about 1 year ago

  • Is duplicate of Bug #25979: Web UI Doesn't Load Properly: Uncaught TypeError added

#12 Updated by William Grzybowski about 1 year ago

  • Status changed from 15 to Screened

I can try upgrading dojo toolkit, however I have not been able to locally reproduce this issue yet.

#13 Updated by Adam Best about 1 year ago

Seeing this issue as well, enabling Fast 3G causes the page to load normally. Occurring in both Chrome and Edge, haven't tested within any other browsers.

Windows 10 Pro, 64-bit
Chrome 61.0.3163.100
Microsoft Edge 40.15063.0.0
FreeNAS-11.0-U4 (54848d13b)

#14 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #26007: Old GUI is not loading correctly in Chrome. added

#15 Updated by Dru Lavigne about 1 year ago

  • Status changed from Screened to Closed: Duplicate

#16 Updated by Dru Lavigne about 1 year ago

  • Status changed from Closed: Duplicate to Screened

#17 Updated by William Grzybowski about 1 year ago

  • Priority changed from No priority to Expected
  • Target version changed from 11.1 to 11.1-BETA1

#18 Updated by William Grzybowski about 1 year ago

  • Status changed from Screened to Ready For Release

commit:9c6ad2dd535c847cbbadbf9d6c5c69276037f856|ports should fix that

#19 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Javascript error while opening GUI to Update Dojo Toolkit to 1.12.2

#20 Updated by Dru Lavigne about 1 year ago

  • File deleted (nas.-1505081706719.log)

#21 Updated by John Pierce about 1 year ago

fyi, I'm having this same issue with 9.10.2_U6, the latest Chrome stalls with an error (below)... Will this Dojo fix be pushed to the next 9.10 update, too?

Uncaught TypeError: Cannot read property 'decimalFormat' of undefined
at _7 (NumberTextBox.js?d2eea335a62861928ee8f5474067e12f:4)
at NumberTextBox.js?d2eea335a62861928ee8f5474067e12f:19
at _ce (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at _37 (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at _37 (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8
at _38 (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at _81 (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at _f6 (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)
at HTMLScriptElement._10b (dojo.js?cache=d2eea335a62861928ee8f5474067e12f:8)

#22 Updated by Danny Lacks about 1 year ago

Just FYI, I upgraded FreeNAS from 9 to 11 because I experienced this issue in version 9, but according to ticket #26115 you are not planning to fix this in version 9. However, as you are aware this is still an issue in version 11 as evident in this ticket and #25979. I am watching this ticket to see when it's ready so I can install the patch, but I just wanted to let you know that folks on version 9 will still probably want a patch, as John Pierce points out above. You may want to consider back-porting this patch if it is not too onerous. Thanks!

#23 Updated by Alexander Vodyanoy about 1 year ago

FYI - I'm seeing the same issue on Firefox Beta (aka "Quantum"), version 57. Ironically, page came up fine for me in Chrome, and then came up on Firefox after I refreshed the page. Firefox 57 is due for general release in November, so this issue may soon become much more widespread.

Freenas 11.0-U4, FF57 ("Quantum") on Win10.

#24 Updated by Dru Lavigne about 1 year ago

  • Status changed from Ready For Release to Resolved

#25 Updated by Neil Clark about 1 year ago

Getting this issue, reproduced 2 times immediately after looking at the new UI and then logging out and going back to the classic UI. UI was working fine in chrome with no issues beforehand; fine in IE. Windows 10, Chrome 61.0.3163.100. Currently Freenas 11.0-U4 but did it on a prior version. Cant remember what I was on, just updated today.

#26 Updated by Dru Lavigne about 1 year ago

Neil: this should be fixed for BETA1. If it is not, please create a new ticket.

#27 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #26410: Browser Access to FreeNAS added

#28 Updated by Bonnie Follweiler about 1 year ago

12855
12856

#29 Updated by Dru Lavigne about 1 year ago

  • Is duplicate of Bug #26151: cannot select "start on boot" added

Also available in: Atom PDF