Project

General

Profile

Bug #25849

Cam Errors after Update

Added by Robert Carter about 3 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I upgraded my system from 9.10.2-U5 to 9.10.2-U6 and after which all drives in my system were throwing massive and continuous CAM errors stating that "Status not ready" or "Command Failed Retrying".

I Rolled my system back to U5 and issues are now gone but there is some issue with U6 update and my hardware configuration.

System Specs:
System Board: Asus Z9pa-U8
CPU: Intel Xeon 2603 V2
Memory: 96gb
HDD Controller: 2 LSI SAS 9201

History

#1 Updated by Robert Carter about 3 years ago

  • File debug-freenas-20170912102910.txz added

#2 Updated by Dru Lavigne about 3 years ago

  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin about 3 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

I'm sorry, but I can't imagine why that upgrade could cause such results. The mps(4) driver was not mpdified in 9.10.2 and 11.0 branches for more then a year now. It will get some fixes in further 11.1 release, but it should be mostly a fixes, since that hardware is now a legacy. Could you try updating to some recent 11.0 updates instead, since 9.10 line is now discontinued.

#4 Updated by Alexander Motin about 3 years ago

  • Priority changed from No priority to Important
  • Seen in changed from Unspecified to 9.10.2-U6

#5 Updated by Dru Lavigne about 3 years ago

  • File deleted (debug-freenas-20170912102910.txz)

#6 Updated by Dru Lavigne about 3 years ago

  • Target version set to N/A
  • Private changed from Yes to No

#7 Updated by Robert Carter about 3 years ago

I haven't moved my personal system nor any of our customer systems to 11 yet due to all the uncertainty with coral and the 11 branch. Since this is a File Server we don't like taking any risks and tend to stay back a few updates.

Is 11 Now considered fully tested and ready for Deployment? and is it a complete rewrite, uses the same UI as 9 or is a mixture or both? Finally is there a simple and clear roll back from 11 to 9 if we upgrade a server to test with and find it unstable or simply unusable?

Thanks Again!

#8 Updated by Dru Lavigne about 3 years ago

Robert: 11 is the continuation of the 9 series (from the same development team). It was originally slated to be named 9.10.3 but was renamed to 11 to indicate that it is based on FreeBSD 11 rather than FreeBSD 10. It is quite stable and well QA'd and suited for production as it includes the latest drivers and application updates (eg NFS, SMB, etc.).

#9 Updated by Sean Fagan about 3 years ago

FYI, I am running FreeNAS-11.0-U3 on my production server at home. I've had no problems with it, on a FreeNAS MiniXL.

Also available in: Atom PDF