Project

General

Profile

Bug #25855

ctl.conf Doesn't get generated in current nightly if Available Space Threshold Is Set

Added by Ben Hughes about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Important
Assignee:
William Grzybowski
Category:
Middleware
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

/usr/local/libexec/nas/generate_ctl_conf.py fails with:


Traceback (most recent call last):
File "/usr/local/libexec/nas/generate_ctl_conf.py", line 405, in <module>
main()
File "/usr/local/libexec/nas/generate_ctl_conf.py", line 267, in main
lunthreshold = int(zfslist[zvolname]['volsize'] *
KeyError: 'volsize'

Remove the threshold and ctl.conf gets generated without issue.


Related issues

Is duplicate of FreeNAS - Bug #25758: iSCSI fails to start in latest 11-nightlyClosed: Duplicate2017-09-03

Associated revisions

Revision 5f868532 (diff)
Added by William Grzybowski about 4 years ago

fix(middlewared): notifier.zfs_list output Ticket: #25855

Revision ce54e5fa (diff)
Added by William Grzybowski almost 4 years ago

fix(middlewared): notifier.zfs_list output Ticket: #25855

History

#1 Updated by Dru Lavigne about 4 years ago

  • Status changed from Unscreened to 15
  • Assignee changed from Release Council to William Grzybowski

Ben: do you get the same error on the latest STABLE (U3)?

#2 Updated by Ben Hughes about 4 years ago

No it works in the current stable, i've only found it in the nightly upgrading my test box to get the updates to the isp driver and found ctl.conf was missing.

#3 Updated by Dru Lavigne about 4 years ago

  • Status changed from 15 to Unscreened

#4 Updated by William Grzybowski about 4 years ago

  • Status changed from Unscreened to 15
  • Target version set to Master - FreeNAS Nightlies

Can you get me the output of

midclt call notifier.zfs_list tank/yourzvolname false false false '["volume"]'

Also, are you sure its a zvol being used in the iscsi extent?

#5 Updated by Ben Hughes about 4 years ago

Yep it's definetly a zvol. Even stranger volsize is returned.

midclt call notifier.zfs_list MDS-NAS-FRN-02-HDD-ZP1/Zvol_iSCSI_HDD_ESXi_1 false false false '["volume"]'

{"MDS-NAS-FRN-02-HDD-ZP1/Zvol_iSCSI_HDD_ESXi_1": {"path": "MDS-NAS-FRN-02-HDD-ZP1/Zvol_iSCSI_HDD_ESXi_1", "pool": "MDS-NAS-FRN-02-HDD-ZP1", "name": "Zvol_iSCSI_HDD_ESXi_1", "_ZFSVol__props": {"avail": 3861159079936, "used": 7643136, "usedsnap": 0, "usedds": 7643136, "usedrefreserv": 0, "usedchild": 0, "refer": 7643136, "compression": "lz4", "dedup": "off", "readonly": "off", "description": "ESXi HDD LUN 1", "volsize": 1649267441664}, "parent": null, "children": []}}

#6 Updated by William Grzybowski about 4 years ago

  • Status changed from 15 to Ready For Release
  • Priority changed from No priority to Important

Should be fixed in next nightly, thanks!

#7 Updated by William Grzybowski about 4 years ago

  • Is duplicate of Bug #25758: iSCSI fails to start in latest 11-nightly added

#8 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Ready For Release to Resolved

Also available in: Atom PDF