Project

General

Profile

Bug #25894

Enable IPMI support in collectd

Added by Craig Shiels almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Attempts to use the "Loadplugin ipmi" with collectd fail as there is no ipmi.so shipped with FreeNAS 9.3

This plugin is useful for monitoring fan speeds, temperatures and voltages from hardware devices.


Related issues

Related to FreeNAS - Bug #26297: Integrate IPMI module into UIClosed
Related to FreeNAS - Bug #33141: Disable broken collectd ipmi pluginDone
Is duplicate of FreeNAS - Feature #24270: Record Ipmi sensor data in collectd when available.Closed: Duplicate2017-05-31

Associated revisions

Revision bd853d1c (diff)
Added by Alexander Motin over 1 year ago

Enable IPMI support in collectd.

Ticket: #25894

Revision 4dc4fee0 (diff)
Added by Alexander Motin 6 months ago

Remove IPMI support from collectd.

It seems to be broken from the day one, and rathe rthen fixing it
we should probably update collectd one day.

Ticket: #25894
Ticket: #33141

Revision 4f0388a8 (diff)
Added by Alexander Motin 5 months ago

Remove IPMI support from collectd.

It seems to be broken from the day one, and rathe rthen fixing it
we should probably update collectd one day.

Ticket: #25894
Ticket: #33141
(cherry picked from commit 4dc4fee092883cef9a6719d66889c35c43d4dfd4)

Revision 10b502ac (diff)
Added by Alexander Motin 5 months ago

Remove IPMI support from collectd.

It seems to be broken from the day one, and rathe rthen fixing it
we should probably update collectd one day.

Ticket: #25894
Ticket: #33141
(cherry picked from commit 4dc4fee092883cef9a6719d66889c35c43d4dfd4)

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Release Council to Alexander Motin

Sasha: can this module be added to the build?

#2 Updated by Alexander Motin almost 2 years ago

  • Status changed from Unscreened to Screened
  • Priority changed from No priority to Nice to have
  • Target version set to 11.1
  • Seen in changed from 9.3-RELEASE to 11.0-U4

It should be trivial one line change in port configuration. It just need be checked that it builds and works.

#3 Updated by Craig Shiels almost 2 years ago

Building ipmi on FreeBSD 9.3 required extra packages: OpenIPMI and popt. There may be one other.

#4 Updated by Alexander Motin over 1 year ago

  • Status changed from Screened to 19

I've added IPMI option to collectd. Will try it on next build.

#5 Updated by Dru Lavigne over 1 year ago

  • Subject changed from collectd does not support ipmi plugin to Enable IPMI support in collectd
  • Target version changed from 11.1 to 11.1-BETA1

#6 Updated by William Grzybowski over 1 year ago

  • Is duplicate of Feature #24270: Record Ipmi sensor data in collectd when available. added

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore over 1 year ago

Mav, this seems OK from build side, does it appear to work on runtime?

#8 Updated by Alexander Motin over 1 year ago

It does builds and loads in VMware, but I haven't tried it on real IPMI hardware yet.

#9 Updated by Dru Lavigne over 1 year ago

  • Related to Bug #26297: Integrate IPMI module into UI added

#10 Updated by Dru Lavigne over 1 year ago

  • Status changed from 19 to Resolved

#11 Updated by Bonnie Follweiler over 1 year ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

#12 Updated by Alexander Motin 12 months ago

  • Related to Bug #33141: Disable broken collectd ipmi plugin added

Also available in: Atom PDF