Project

General

Profile

Bug #25928

Fatal Python error: failed to get random numbers to initialize Python after recent nightly-11 updates

Added by Mamdoh AlObaidy almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Behaves correctly
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

FreeNAS Mini XL

ChangeLog Required:
No

Description

Hi all,

I was asked to file a bug report (https://forums.freenas.org/index.php?threads/recent-nightly-11-updates-fatal-python-error-failed-to-get-random-numbers-to-initialize-python.57915/)

So, after recent (?16-17 September) FreeNAS-11 nightly updates; when the system reboots, the following happens:

A) I get a series of errors as follows:

pid xyz* (python3.6), uid 0: exited on signal 6 (core dumped) (* xyz = Random sequential string number.)
Abort trap (core dumped)
Fatal Python error: failed to get random numbers to initialize Python

After that, I get an endless flood of the pid xyz* (python3.6), uid 0: exited on signal 6 (core dumped), even after force restarting the system several times, and FreeNAS never loads.

B) I also get a few additional errors in the console like:

root: /etc/rc: WARNING: failed precmd routine for minio
collectd3005: plugin_load: Could not find plugin "zfs_arc_v2" in /usr/local/lib/collectd
root: /etc/rc: WARNING: failed to start collectd

Thanks,
Mamdoh

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to 15

Do you get the same error on 11.0-U3?

#2 Updated by Mamdoh AlObaidy almost 3 years ago

I have not tried 11.0-U3 or any of the stable releases to be honest (I know. Big mistake on a production machine. I just like to live dangerously :)). I've always been on the nightly train, with semi-regular (weekly maybe?) updates. I, however, experienced the same issue after the 16-17 September's updates on both a physical machine; which was recently updated, and a virtual machine; which was not updated since May 2017 probably. Pretty much the same case scenario. After update, it reboots fine for one time with some errors in the console. After the second reboot, I run into the same sequence of events described in the original post and FreeNAS stops running.

#3 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Behaves correctly
  • Target version set to N/A

Tsk tsk... The nightly train is for testing purposes which means it can be at a random stage of brokenness at any point in time. I'll close out this bug for now. Please reopen if you can reproduce the error on the latest STABLE.

Note that if you do decide to move to STABLE, you will need to reinstall. However, if you reinstall into a BE (one of the install options), it will keep your current BEs associated with your nightly install (meaning you can choose to reboot into either version).

Also available in: Atom PDF