Project

General

Profile

Bug #25964

SABnzbd 2.3.0 update fails

Added by Shawn Bolton about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
No priority
Assignee:
Joshua Ruehlig
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Attempting to update from 2.2.0 to 2.3.0 via the FreeNAS GUI the update fails with the following text displayed in update window.:

Request Method: POST
Request URL: http://192.168.2.45/plugins/plugin/update/7/
Software Version: FreeNAS-11.0-U3 (c5dcf4416)
Exception Type: MiddlewareError
Exception Value:
[MiddlewareError: b'There was a problem creating the PBI']
Exception Location: ./freenasUI/middleware/notifier.py in update_pbi, line 2548
Server time: Sun, 24 Sep 2017 21:41:32 -0400
Traceback

Environment:

Software Version: FreeNAS-11.0-U3 (c5dcf4416)
Request Method: POST
Request URL: http://192.168.2.45/plugins/plugin/update/7/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
39. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
162. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/plugins/views.py" in plugin_update
238. if notifier().update_pbi(plugin=iplugin):
File "./freenasUI/middleware/notifier.py" in update_pbi
2548. raise MiddlewareError("There was a problem creating the PBI")

Exception Type: MiddlewareError at /plugins/plugin/update/7/
Exception Value: [MiddlewareError: b'There was a problem creating the PBI']

Request information

GET

No GET data
POST

Variable Value
__form_id 'form_str'
FILES

No FILES data
COOKIES

Variable Value
sessionid 'gd77hefmsbcrrlctdpn0o9hgwotbb6zy'
csrftoken 'e8QkD5iJM6AIlSsIAXDBV421EQdKIqwuTi0B6kfhCwJJQOeFgQFcNlJzQwtVByKe'
fntreeSaveStateCookie 'root%2Croot%2F59%2F60%2Croot%2F59%2F60%2F61%2F62%2Croot%2F59%2F60%2F61%2Croot%2F29%2F30%2Croot%2F29%2F33'
META

Variable Value

History

#1 Updated by Shawn Bolton about 4 years ago

  • File debug-freenas-20170924220233.txz added

#2 Updated by Shawn Bolton about 4 years ago

  • Seen in changed from Unspecified to 11.0-U3

#3 Updated by Dru Lavigne about 4 years ago

  • Assignee changed from Release Council to Kris Moore

#4 Updated by Shawn Bolton almost 4 years ago

I now see what the issue is, 2.3.0 is not in the repo, I am running SABnzbd 2.2.1 but the Freenas plugin page is reporting version 2.2.0 as being currently installed.

#5 Updated by Dru Lavigne almost 4 years ago

  • Assignee changed from Kris Moore to Joshua Ruehlig

Joshua: would you be able to update this plugin?

#6 Updated by Dru Lavigne almost 4 years ago

  • File deleted (debug-freenas-20170924220233.txz)

#7 Updated by Dru Lavigne almost 4 years ago

  • Private changed from Yes to No

#8 Updated by Joshua Ruehlig almost 4 years ago

  • Status changed from Unscreened to Screened
  • Target version set to 11.0

yeah, it's on my todo list.

#9 Updated by Joshua Ruehlig almost 4 years ago

  • Status changed from Screened to Fix In Progress

I built this yesterday. I dont think the updates PBI has propigated yet across the CDN.

#10 Updated by Dru Lavigne almost 4 years ago

  • Target version changed from 11.0 to 11.1

#11 Updated by Dru Lavigne almost 4 years ago

  • Status changed from Fix In Progress to Resolved
  • Target version changed from 11.1 to Master - FreeNAS Nightlies

Also available in: Atom PDF