Project

General

Profile

Bug #26113

Freenas disconnects SCSI-Drives in Hyper-V

Added by Hans Wurscht almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Insufficient Info
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Ryzen 1700x
Asrock AB350 Pro4 (i know, not the best choice, but this was all I had)
Kingston DDR4 2x16GB ECC RAM (soon 64 GB RAM, when I have the money :) )
2x 32GB SSD (software mirrored with diskpart, for Hyper-V Server 2016 & FreeNAS 11 VHD)
6x 4TB western digital Red
2x Gigabit onboard LAN (Intel)

ChangeLog Required:
No

Description

Hello all,
I want to report a bug.

Setup:
Freenas 11 U4 is installed on a fixed size 10 GB VHD in Hyper-V Server 2016. All Guest Services are offered. The VM boots without issues.
The VM has 4 Virtual CPU´s and 24 GB of RAM assigned.

Description:
Physical hard drives cannot be seen or configured in Freenas when attached by the virtual SCSI-Adapter as passthrough disks in Hyper-V.
If I create a .VHDX virtual hard drive on the hard drives (4TB size), they can be attached without issues and I can create Volumes in Freenas etc.
If the exact same hard drive is connected to the virtual IDE adapter as passthrough disk, it can be attached without issues, I can create Volumes etc.

Boot code (maybe it helps, only one disk attached):

storvsc1: <Hyper-V SCSI> on vmbus0
(probe0:storvsc1:0:0:0): storvsc scsi_status = 2
da1 at storvsc1 bus 0 scbus4 target 0 lun 0
da1: <WDC WD40EFRX-68WT0N0 82.0> Fixed Direct Access SCSI device
da1: Serial Number WD-WCC4E2PXU2E8
da1: 300.000MB/s transfers
da1: Command Queueing enabled
da1: 3815447MB ((7814037168 512 byte sectors)
da1 at storvsc1 bus 0 scbus4 target 0 lun 0
da1: <WDC WD40EFRX-68WT0N0 82.0> s/n WD-WCC4E2PXU2E8 detached
(da1:storvsc1:0:0:0): storvsc scsi_status = 2
g_access(918): provider da1 has error
g_access(918): provider da1 has error
g_access(918): provider da1 has error
g_access(918): provider da1 has error
(da1:storvsc1:0:0:0): Periph destroyed

Issue:
Passthrough with disks connected to virtual SCSI-Adapter in Hyper-V not working.

Thanks for your help and kind regards
BabaJega

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Private changed from No to Yes

#2 Updated by Alexander Motin almost 3 years ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1

Unfortunately debug provided gives not enough information and I don't have Hyper-V instance to reproduce it right now. Could you try to add loader tunable `kern.cam.dflags=1` to make kernel more chatty, and after reboot attach another set of debug info.

#3 Updated by Alexander Motin almost 3 years ago

  • Target version changed from 11.1 to 11.2-BETA1

#4 Updated by Hans Wurscht almost 3 years ago

  • File debug-freenas-20171011132725.tgz added

Hello there,

the debug file is attached and as you said the kernel got more "chatty".
Hopefully this helps you because I have tested some more things and was not successful...

Kind Regards
BabaJega

#5 Updated by Alexander Motin almost 3 years ago

  • Status changed from 15 to Investigation

From the debug information it seem to be a problem between Hyper-V and its virtual SCSI HBA FreeBSD driver. I've written email to FreeBSD committer from Microsoft maintaining it, hoping he will be able to help with this.

#6 Updated by Alexander Motin almost 3 years ago

  • Status changed from Investigation to 15

Hans, could you please try latest nightly builds to make sure the problem was not somehow fixed in time since 11.0 release?

#7 Updated by Alexander Motin almost 3 years ago

Hans, the developer responded with: "The patch/update ids of the WS2016 will be helpful. And the location (it's a Hyper-V configuration parameter, 0~63) of the virtual SCSI disk. And the id of the virtual SCSI disk controller." Could you answer those questions?

#8 Updated by Alexander Motin almost 3 years ago

  • Private changed from Yes to No

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20171008131749.tgz)

#10 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-freenas-20171011132725.tgz)

#11 Updated by Dru Lavigne almost 3 years ago

  • Status changed from 15 to Closed: Insufficient Info
  • Target version changed from 11.2-BETA1 to N/A

Also available in: Atom PDF