Project

General

Profile

Bug #26168

mdns is not working

Added by Sean Fagan almost 3 years ago. Updated almost 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

It worked in 201710022039, doesn't work in 1201710120511.

On the system, "ping mininas.local" works (it's localhost), so the resolving and announcing is working. But on any other host, it gets unknown host. I've attached kdump from running mdnsd -debug while trying to ping it from another host.

This is a FreeNAS Mini, but only one port is configured, as well as a debug file.


Related issues

Related to FreeNAS - Bug #26531: Make sure mDNS startsResolved2017-11-07

History

#1 Updated by John Hixson almost 3 years ago

  • Status changed from Untriaged to Screened
  • Target version set to 11.1

#2 Updated by Sean Fagan almost 3 years ago

I just added an SMB share, and enabled the SMB service... and then it worked.

#3 Updated by Dru Lavigne almost 3 years ago

  • File deleted (kdump.out)

#4 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug-mininas-20171012123658.tgz)

#5 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Screened to Closed: Cannot reproduce
  • Target version changed from 11.1 to N/A

Sean, thanks for the update. Closing out.

#6 Updated by Dru Lavigne almost 3 years ago

  • Private changed from Yes to No

#7 Updated by Dru Lavigne almost 3 years ago

  • Related to Bug #26531: Make sure mDNS starts added

Also available in: Atom PDF