Project

General

Profile

Feature #26178

Umbrella #25917: Umbrella: GUI to middlewared

Convert Services:TFTP to Middlewared

Added by William Grzybowski about 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Regression
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Estimated time:
Sprint:
Severity:
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
Yes
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Ticket to track transfer of business logic from Django/GUI to middlewared and making use of middleware client in GUI.

Associated revisions

Revision a479c978 (diff)
Added by Vladimir Vinogradenko 11 months ago

fix(tftp): Make tftp onestart work

Don't use srv_enabled in ix-inetd to check whether we should append tftpd to inetd.conf
It will be false when tftp service is disabled, and onestart command was issued

Ticket: #26178

Revision 9a299089 (diff)
Added by Vladimir Vinogradenko 11 months ago

fix(tftp): Make tftp onestart work

Don't use srv_enabled in ix-inetd to check whether we should append tftpd to inetd.conf
It will be false when tftp service is disabled, and onestart command was issued

Ticket: #26178

History

#1 Updated by William Grzybowski about 1 year ago

#2 Updated by William Grzybowski about 1 year ago

  • Copied to Feature #26179: Convert Services:DynDNS to Middlewared added

#3 Updated by William Grzybowski about 1 year ago

  • Copied to deleted (Feature #26179: Convert Services:DynDNS to Middlewared)

#4 Updated by William Grzybowski about 1 year ago

  • Copied from deleted (Feature #25944: Add Services:Rsync to Middlewared)

#5 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Unscreened to Fix In Progress

#6 Updated by Vladimir Vinogradenko about 1 year ago

  • Status changed from Fix In Progress to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

#7 Updated by William Grzybowski about 1 year ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#8 Updated by William Grzybowski about 1 year ago

  • Target version changed from 11.1 to 11.1-BETA1

#9 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Services:TFTP - GUI to Middlewared to Convert Services:TFTP to Middlewared

#10 Updated by Vladimir Vinogradenko 12 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#11 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved

#12 Updated by Nick Wolff 11 months ago

  • Status changed from Resolved to Unscreened
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski
  • Priority changed from Expected to Regression
  • Target version changed from 11.1-BETA1 to 11.1
  • QA Status Test Fails FreeNAS added
  • QA Status deleted (Not Tested)

So it looks like we activate tftp by having it in /etc/inetd.conf. When I turn on the service tftp doesn't seem to work, nothing is bound to port 69, and the line in inetd.conf is still filtered out. The service light turns green

Please let me know what questions you have or if I'm missing something here.

#13 Updated by Nick Wolff 11 months ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko

#14 Updated by Vladimir Vinogradenko 11 months ago

  • Status changed from Unscreened to Needs Developer Review
  • Assignee changed from Vladimir Vinogradenko to William Grzybowski

Nick, I've found and fixed the case where "Start on boot" checkbox was unchecked and user clicked "Start now". Then the service light turned green, but inetd.conf was not updated and TFTP was not working. Was this your case?

#15 Updated by Nick Wolff 11 months ago

Correct it looks like that was the issue. I will retest when we get in 11.1-rc2

Thanks,

Nick

#16 Updated by William Grzybowski 11 months ago

  • Status changed from Needs Developer Review to Reviewed by Developer
  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • QA Status Not Tested added
  • QA Status deleted (Test Fails FreeNAS)

#17 Updated by Vladimir Vinogradenko 11 months ago

  • Status changed from Reviewed by Developer to Ready For Release

#18 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1 to 11.1-RC2

#19 Updated by Nick Wolff 11 months ago

  • Needs QA changed from Yes to No
  • QA Status Test Passes FreeNAS added
  • QA Status deleted (Not Tested)

Test passes

Tested starting and stopping service with on-boot flag enabled and disabled.

#20 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.1-RC2 to 11.1-RC3

#21 Updated by Dru Lavigne 11 months ago

  • Status changed from Ready For Release to Resolved

#22 Updated by Joe Maloney 6 months ago

  • Needs Automation changed from No to Yes

Also available in: Atom PDF