Project

General

Profile

Feature #26292

Add support for Intel X553 to ixgb(4)

Added by Daniel Claesson 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Important
Assignee:
Alexander Motin
Category:
OS
Target version:
Estimated time:
Sprint:
Severity:
New
Backlog Priority:
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Hi,

I found out that the Intel X553 network controller don't work as FreeNAS is unable to detect any network interfaces.
The board i have at hand is SuperMicro A2SDi-2C-HLN4F.
Link: https://www.supermicro.com/products/motherboard/atom/A2SDi-2C-HLN4F.cfm

I'm working with the SuperMicro support to flesh out a good and working UEFI/BIOS for the board. At the moment i'm running a BETA UEFI and managed to get FreeNAS 11.0-U4 installed.

I can assist helping devs on trying out builds etc on my hardware if it helps.

Best Regards
Daniel Claesson

Associated revisions

Revision 3c4f9580 (diff)
Added by Dru Lavigne 12 months ago

Mention updates to ixgb(4).
Ticket: #26292

Revision 051afea3 (diff)
Added by Dru Lavigne 12 months ago

Fix driver name.
Ticket: #26292

History

#1 Updated by Daniel Claesson 12 months ago

  • Subject changed from Intel X553 network controller driver is missing in 9.11-u4 to Intel X553 network controller driver is missing in FreeNAS 11.0-U4

#2 Updated by Dru Lavigne 12 months ago

  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin 12 months ago

  • Status changed from Unscreened to 15
  • Target version set to 11.1-BETA1

Could you please try nightly FreeNAS build/train? It includes updated Intel NIC driver, that mentions X553 in the code.

#4 Updated by Daniel Claesson 12 months ago

Yes of course, i have dowloaded this ISO, is it the one you want me to test?
"FreeNAS-11-MASTER-201710220505-937d04e.iso"

Best Regards
Daniel

#5 Updated by Alexander Motin 12 months ago

Yes, that would be good to try.

#6 Updated by Daniel Claesson 12 months ago

Hi, im having trouble booting that ISO and i suspect it is "detected" as a BIOS/Legacy. This MLB need UEFI only to work.
I will try a couple of more times, but is there a way to obtain a UEFI only ISO?

Best Regards
Daniel Claesson

#7 Updated by Alexander Motin 12 months ago

We do not build other images. This should boot on everything. But you may install on any other system and just move the boot disk. Or you may insert some other NIC and update FreeNAS to nightly via regular updating mechanism.

#8 Updated by Daniel Claesson 12 months ago

Ok i understan.

Well guess what it i another wonky thing about that board, power reset from iKVM and i will not boot any iso or thumb drive. But if one completely powers down and then power up it works.
This is reported back to SuperMicro to check if it is by design or yet another "bugg".

So i'm installing just now and will report back as soon as it is done.

Best Regards
Daniel Claesson

#9 Updated by Dru Lavigne 12 months ago

  • Target version changed from 11.1-BETA1 to 11.1

#10 Updated by Daniel Claesson 12 months ago

An update.

With the latest nightly build the Intel X533 works. I haven't done any extended test yet due to time restrain. I will do further testing this week.
Will this go to stable once FreeNAS hits v11.1?

Best Regards
Daniel Claesson

#11 Updated by Alexander Motin 12 months ago

  • Status changed from 15 to Ready For Release

Yes, it will.

#12 Updated by Dru Lavigne 12 months ago

  • Subject changed from Intel X553 network controller driver is missing in FreeNAS 11.0-U4 to Add support for Intel X553 to ixgb(4)

#13 Updated by Dru Lavigne 12 months ago

  • Status changed from Ready For Release to Resolved
  • Target version changed from 11.1 to 11.1-BETA1

#14 Updated by Daniel Claesson 12 months ago

Perfect.

Thanks a lot for your quick feedback, very well done sir.

Best Regards
Daniel Claesson

#15 Updated by Joe Maloney 12 months ago

  • Needs QA changed from Yes to No

Also available in: Atom PDF